Issue 101786 - error in expecting makro
Summary: error in expecting makro
Alias: None
Product: Build Tools
Classification: Code
Component: code (show other issues)
Version: DEV300m47
Hardware: Unknown All
: P2 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2009-05-11 21:50 UTC by maand
Modified: 2013-08-07 15:34 UTC (History)
5 users (show)

See Also:
Issue Type: PATCH
Latest Confirmation in: ---
Developer Difficulty: ---

Ah, fun, my browser has eaten part of the URL, here it is as an attachment. (1.35 KB, patch)
2009-07-03 09:44 UTC, kendy
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description maand 2009-05-11 21:50:59 UTC
I tried to compile OOoDEV300_m47 from source on my openSUSE-11.1-x64-box. But
the build breaks short after I started make (dmake). I get the following error:
dmake present in /local/ooovanilla/DEV300_m47/solenv/unxlngx6/bin/dmake

dmake copied to /local/ooovanilla/DEV300_m47/solenv/unxlngx6/bin/dmake
build -- version: -

Building module solenv
dmake:  /local/ooovanilla/DEV300_m47/solenv/inc/startup/  line 23: 
Error: -- Expecting macro or rule defn, found neither

ERROR: Error 65280 occurred while making /local/ooovanilla/DEV300_m47/solenv
rmdir /tmp/25162
make: *** [all] Fehler 1

I run configure with the following options:
--with-lang="de" --disable-mozilla --disable-binfilter

I used the following environment variables:
export nodep=TRUE

I tried to comment out the line 23 (and 21 to 23), but nothing worked. Then I
get an error, that point me to line 40. If I comment out that line, dmake stops
at line 46.
Comment 1 maand 2009-05-13 18:50:04 UTC
I tested again with OOoDEV300_m48 and the error is still there.
Because it is a build problem, I set the priority to 1.
Comment 2 Martin Hollmichel 2009-05-14 07:03:15 UTC
Comment 3 hjs 2009-05-14 11:16:42 UTC line 23 is the place where dmake imports your environment variables.
please check your environment variables or attach a dump.
Comment 4 maand 2009-05-14 14:41:34 UTC
Please give me a short instruction, which environment variables I should check 
and how I could get a dump.
Comment 5 hjs 2009-05-14 15:12:41 UTC
depending on your shell, you could do a dump with:
bash: set > envdump.txt
tcsh:env > envdump.txt

to be honest, i don't know what to look for. in general, things that are unusual
for an environment like e.g. variablenames that contain blanks or dollar signs
or things like that.
Comment 6 noel.power 2009-06-11 08:41:58 UTC
I had exactly the same problem yesterday, in the end I debugged at dmake, the
problem is caused by strange entries in the env caused by enabling pulseaudio
support. To fix just go to yast, sound, disable pulseaudio support

you will find the entries by

env | grep alias

and the will look something like

alias timidity=timidity -Oe
alias sox=padsp sox
alias aumix=padsp aumix
Comment 7 maand 2009-06-14 09:37:36 UTC
Thanks for the solution. It worked after a restart of openSuSE / soundserver.
Should we write this into the wiki?
Comment 8 kendy 2009-06-15 14:20:46 UTC
This clearly should not be 'RESOLVED INVALID' ;-)  These aliases are perfectly
valid, and should be no problem for dmake...
Comment 9 hjs 2009-06-15 14:39:03 UTC
alias timidity=timidity -Oe

may be a valid command line to create an alias but to have this entry in the
environment you have to use

"alias timidity"="timidity -Oe"

or similar, which is atleast questionable...
Comment 10 kendy 2009-06-15 16:17:13 UTC
hjs: Sorry, I overlooked that the aliases are not a part of the env output. 
Anyway, a way to set such a broken thing is:

$ env 'GGG HHH'='some value' bash
$ env | grep GGG
GGG HHH=some value
Comment 11 hjs 2009-07-02 14:13:15 UTC
now that we agreed that this kind of variables is broken, any objections to
close this issue again?
Comment 12 kendy 2009-07-03 09:41:16 UTC
Well, actually this is trivial to fix in dmake, there are workarounds for such
cases anyway, so... ;-)  The patch is here, please do you have a CWS into which
could this go?
Comment 13 kendy 2009-07-03 09:44:15 UTC
Created attachment 63346 [details]
Ah, fun, my browser has eaten part of the URL, here it is as an attachment.
Comment 14 hjs 2009-09-10 11:17:11 UTC
Comment 15 kyoshida 2009-09-17 22:35:26 UTC
I just got the same problem, when trying to build m59 based CWS'es.  kendy's
patch fixed it.
Comment 16 kyoshida 2009-09-17 22:39:07 UTC
So, what's the holdup for integrating this patch?
Comment 17 maand 2010-01-09 17:52:09 UTC
I tried with the patch but nothing changed.
The message in the shell:
. ./* && \
        ./bootstrap && \
                cd instsetoo_native && ../solenv/bin/ --all

dmake present in

dmake copied to
build -- version: 275224

Building module solenv

Entering /local/ooovanilla/ooodev_hg/working_DEV300/solenv
/local/ooovanilla/ooodev_hg/working_DEV300/solenv/inc/startup/  line
23:  Error: -- Expecting macro or rule defn, found neither

1 module(s):
need(s) to be rebuilt


Attention: if you fix the errors in above module(s) you may prolongue your the
build issuing command:

        build --all:solenv

make: *** [all] Fehler 1
Comment 18 maand 2010-01-09 19:17:08 UTC
I tried again with disable pulse-audio support in Yast2 and then restart my
Linux machine. Then every thing works.
If I restart the sound server with /etc/init.d/alsasound restart that doesn't
Comment 19 kendy 2010-01-11 17:14:00 UTC
andreasma: Can you please try with the 'env' from my comment from Mon Jun 15
15:17:13 +0000 2009, with the pulse-audio disabled?  Without the patch, dmake
should break, with that, it should be OK.  If you get breakages even with the
patch in this scenario, I am afraid that wrong executable is being called.
Comment 20 Rob Weir 2013-03-11 15:03:15 UTC
I'm adding this comment to all open issues with Issue Type == PATCH.  We have 220 such issues, many of them quite old.  I apologize for that.  

We need your help in prioritizing which patches should be integrated into our next release, Apache OpenOffice 4.0.

If you have submitted a patch and think it is applicable for AOO 4.0, please respond with a comment to let us know.

On the other hand, if the patch is no longer relevant, please let us know that as well.

If you have any general questions or want to discuss this further, please send a note to our dev mailing list: