Issue 101821 - Crash printing selection with just one rowof table selected
Summary: Crash printing selection with just one rowof table selected
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: printing (show other issues)
Version: OOo 3.0.1
Hardware: All All
: P2 Trivial with 1 vote (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords: crash, regression
: 98129 (view as issue list)
Depends on:
Blocks: 99999
  Show dependency tree
 
Reported: 2009-05-12 13:13 UTC by kpalagin
Modified: 2013-08-07 14:44 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description kpalagin 2009-05-12 13:13:54 UTC
Using 3.0.1 on WinXP.
Repro:
1. New text doc, table 1 row by 1 column.
2. type random string in the cell, press Enter and type one more random word.
3. use row selector tool (in the left margin of the table mouse pointer turns 
into thick right arrow) to select that cell.
4. File-Print-Selection-OK.
5. Crash, thus P2.
Comment 1 kpalagin 2009-05-12 13:14:29 UTC
also happens with m47.
Comment 2 helenrussian 2009-05-13 05:10:06 UTC
Confirm on Linux.
Comment 3 michael.ruess 2009-05-13 13:16:08 UTC
MRU->OS: insert a table cell having two paragraphs, select the cell and print
the selection -> crash.
Comment 4 kpalagin 2009-05-13 13:36:45 UTC
You need to use row selector for the crash to happen - simply seelcting via 
Table-Seelct-Cell is not enough.

BTW, this is regression since at least 2.1.
Comment 5 kpalagin 2009-05-15 08:35:18 UTC
Crash report id rbp7qkc.
2.4.2 also does not crash.
Comment 6 kpalagin 2009-08-12 10:53:06 UTC
Any chance to target this for 3.2?
Comment 7 lemrichard 2009-10-29 17:59:52 UTC
It will also crash if you select all the cells in a table and try to print the
selection. (OpenOffice/3.1.1 - Ubuntu 9.10)
Comment 8 lemrichard 2009-10-29 18:00:39 UTC
It will also crash if you select all the cells in a table and try to print the
selection. (OpenOffice/3.1.1 - Ubuntu 9.10)
Comment 9 Mechtilde 2009-11-24 15:37:49 UTC
I can confirm it with 3.1.1 and OOO320_m5

For me it is a stopper
Comment 10 Regina Henschel 2009-11-24 15:50:52 UTC
In CWS printerpullpages it crashes immediately after clicking on "Selection" in
tab "General".
Comment 11 uwe.luebbers 2009-11-24 15:59:17 UTC
Adjusted target
Comment 12 Oliver Specht 2009-11-27 13:52:53 UTC
Fixed in cws os139 in 
sw/source/view/vprint.cxx

The same crash occurred if such selections are exported to PDF.
Comment 13 Oliver Specht 2009-11-27 13:54:29 UTC
*** Issue 98129 has been marked as a duplicate of this issue. ***
Comment 14 Oliver Specht 2009-12-02 09:43:49 UTC
Reassigned for verification
Comment 15 michael.ruess 2009-12-04 14:29:28 UTC
Verified fix in CWS os139.
Comment 16 andreschnabel 2010-01-06 19:48:37 UTC
ok in OOo3.2RC1