Issue 101825 - Loop with Find and Replace in redlining mode when using "Replace All"
Summary: Loop with Find and Replace in redlining mode when using "Replace All"
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: DEV300m47
Hardware: All All
: P2 Trivial (vote)
Target Milestone: ---
Assignee: helge.delfs
QA Contact: issues@sw
URL:
Keywords: regression
: 102093 (view as issue list)
Depends on:
Blocks:
 
Reported: 2009-05-12 13:47 UTC by helge.delfs
Modified: 2013-08-07 14:44 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description helge.delfs 2009-05-12 13:47:34 UTC
- New writer document
- Write 'redling test => OK_1'
- Edit -> Changes -> Record
- Edit -> Find & Replace
- Seach for text = OK_1
- Replace with text = OK_2
- Click 'Replace all'
- Loop

This was found in automated test 'w_redlining.bas' and determined to be ok in
DEV300m46
Comment 1 stefan.baltzer 2009-05-25 14:55:23 UTC
When in redlining mode, the deleted string (displayed in "striketrough") is
found again when the document is re-searched from the top. That's OK. 
But when doing "Replace all" then a dialog "Search string replaced xyz times"
should pop up and the F&R stops.
Since DEV300_m47, it looks like this dialog does not pop up. therefore "Replace
all" does not stop when the entire document was gone through and finds the same
"deleted" string again and adds one more replacement string on every round.
Set keyword "regression".
Comment 2 stefan.baltzer 2009-05-25 14:57:56 UTC
*** Issue 102093 has been marked as a duplicate of this issue. ***
Comment 3 stefan.baltzer 2009-05-25 15:26:05 UTC
*** Issue 102093 has been marked as a duplicate of this issue. ***
Comment 4 stefan.baltzer 2009-05-25 15:52:45 UTC
Put FHA on c/c.
Comment 5 Oliver Specht 2009-06-17 12:24:44 UTC
Fixed in cws os132 in
sw/source/core/crsr/findtxt.cxx

->b_michaelsen: Has been introduced by swrefactormarks2. SwDoc::Replace()
returned the result of the replacement in differen order (Point/Mark)
Comment 6 Oliver Specht 2009-07-13 14:49:49 UTC
Reassigned for verification
Comment 7 michael.ruess 2009-07-15 08:06:06 UTC
Verified in CWS os132; test w_redlining.bas ran corretly on Win and Linux.
Comment 8 helge.delfs 2009-10-19 13:43:23 UTC
ok in current MWS DEV300m61