Issue 101859 - Menus and controls are not accessible by speech recognition
Summary: Menus and controls are not accessible by speech recognition
Status: CLOSED DUPLICATE of issue 70567
Alias: None
Product: performance
Classification: Code
Component: www (show other issues)
Version: current
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: not determined
Assignee: issues@performance
QA Contact: issues@performance
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-13 06:52 UTC by kmar
Modified: 2009-05-13 10:29 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description kmar 2009-05-13 06:52:42 UTC
Many Windows-based programs have menus and controls that can be accessed by 
speech recognition software (e.g. Dragon NaturallySpeaking). Openoffice's 
performance with speech recognition software could be vastly improved if whole 
word equivalents (as well as shortcuts) to menu items and controls were 
recognized.

I say "press alt+f" using DNS8.1 and OO3.0 and the file menu opens. (if I 
said "file" it would go to the open document as text). 
Then I say "New" and the new sub menu opens (because N, the first letter, is 
the shorcut.)
Now if I say "Text document" or "Spreadsheet" the correct document type opens 
but when it does it gets "ext document" or "preadsheet" sent to it.  (Menu 
items that do not start with the shortcut call the wrong document type).

Thus it would help if the whole menu item name were also its "keyboard 
equivalent".
Comment 1 malte_timmermann 2009-05-13 10:27:56 UTC
Would be done with 70567, so I mark this a duplicate...

*** This issue has been marked as a duplicate of 70567 ***
Comment 2 malte_timmermann 2009-05-13 10:29:51 UTC
Closing duplicate issue...