Issue 101863 - [Interoperability] can't open *.xlsx file which is protected via MS 2007
Summary: [Interoperability] can't open *.xlsx file which is protected via MS 2007
Status: CLOSED DUPLICATE of issue 92645
Alias: None
Product: Calc
Classification: Application
Component: open-import (show other issues)
Version: OOO310m11
Hardware: PC All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: spreadsheet
QA Contact: issues@sc
URL:
Keywords:
Depends on:
Blocks: 84405
  Show dependency tree
 
Reported: 2009-05-13 07:52 UTC by amy2008
Modified: 2009-06-25 12:35 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
reproduce doc (12.34 KB, application/vnd.ms-excel)
2009-05-13 07:55 UTC, amy2008
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description amy2008 2009-05-13 07:52:28 UTC
Can reproduce it in OOo310m11 on WinXP, Vista and Fedora.

How to reproduce it
1 Create a new file named ms.xlsx with MS 2007, then protect document for ms.xlsx
2 Open ms.xlsx with OOo310m11

Result
an error dialog appears: General Error. General input/output error.

Expectation
Open the file successfully.
Comment 1 amy2008 2009-05-13 07:55:24 UTC
Created attachment 62218 [details]
reproduce doc
Comment 2 amy2008 2009-05-13 07:59:54 UTC
ms.xlsx = i101863.xlsx
Comment 3 caolanm 2009-06-25 12:34:59 UTC
Even password-less protected gets encrypted inside an ole2 structure, probably
with the classic velvetsweatshop

*** This issue has been marked as a duplicate of 92645 ***
Comment 4 caolanm 2009-06-25 12:35:28 UTC
close as dup