Issue 102004 - WW8: tables in RTL context not imported/imported wrongly in 3.1
Summary: WW8: tables in RTL context not imported/imported wrongly in 3.1
Status: CLOSED NOT_AN_OOO_ISSUE
Alias: None
Product: Writer
Classification: Application
Component: open-import (show other issues)
Version: OOo 3.1
Hardware: Unknown All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: andreas.martens
QA Contact: issues@sw
URL:
Keywords: regression
Depends on:
Blocks: 101565
  Show dependency tree
 
Reported: 2009-05-17 21:40 UTC by rene
Modified: 2013-08-07 14:43 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
a.doc (88.00 KB, application/msword)
2009-05-17 21:44 UTC, rene
no flags Details
wrong_lands_table.doc (37.50 KB, application/msword)
2009-05-17 21:44 UTC, rene
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description rene 2009-05-17 21:40:35 UTC
[regression to 3.0]

From http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=528836

--- snip ---
i have a doc file that has been loaded well in OOo 3.0, but doesn't load ok 
with current OOo 3.1.
abiwird loads ite correctly too.
i will attach the file.
--- snip ---

and

-- snip ---
I've been bitten by this too. Many word documents don't open correctly
with 3.1, but used to with OOo 3.0. Some tables don't show at all, I
don't know what might be the reason.
--- snip ---

and last but not least

--- snip ---
I got the same problem, too. In OOo (version 3.1.0-1, build 9399),
the tables in attachment "a.odt" is displayed correctly, while
some of them are misplaced or disappeared in attachment "a.doc",
which was created by saving "a.odt" as MS Word 97/2000/XP format
in the same OOo. But in OOo 3.0.1-9ubuntu3 (build 9379), both file
are displayed correctly.
--- snip ---

I can reproduce this with a vanilla OOo 3.1.0 from www.openoffice.org
Comment 1 rene 2009-05-17 21:44:02 UTC
Created attachment 62331 [details]
a.doc
Comment 2 rene 2009-05-17 21:44:45 UTC
Created attachment 62332 [details]
wrong_lands_table.doc
Comment 3 rene 2009-05-17 21:45:05 UTC
oops, no PATCH but DEFECT
Comment 4 andreschnabel 2009-05-17 21:54:07 UTC
can confirm the problem for wrong_lands_table.doc 

but tha a.doc looks for me the same as the original a.odt (attached to the
debian bug)
Comment 5 rene 2009-05-17 21:57:34 UTC
Probably the a.doc/a.odt guy just "misused" the bug for his document (it
formerly has the bogus title "doesn't import my document correctly anymore",
which of course is such not generic that you can drive truck trough that hole)
Comment 6 rene 2009-05-17 23:21:40 UTC
but then again, the NUS thing is left in 3.1 whereas right in 2.4.1 and 2.4.1
shows the table borders whereas 3.1 doesn't.

(didn't try on 3.0 with this doc)
Comment 7 rene 2009-05-18 00:29:26 UTC
s/left in 3.1 whereas right in 2.4.1/right in 3.1 whereas left in 2.4.1/
Comment 8 michael.ruess 2009-05-25 13:10:54 UTC
"Only" occurs on 64-Linux builds. Already tracked as issue 101451.
Table is not lost - it has wrong spacings. Edit the table via Navigator as
workaround.

*** This issue has been marked as a duplicate of 101451 ***
Comment 9 michael.ruess 2009-05-25 13:38:18 UTC
Closing duplicate.
Comment 10 rene 2009-06-02 15:32:50 UTC
mru: Actually, the submitter of this bug in Debian says it also happens on 32bit
for him
Comment 11 rene 2009-07-06 14:03:22 UTC
> Do not re-open issue 102004 as long as there are two different documents
> attached to it.

Actualkly, I will, because the bugreport *was* about wrong_lands_table.doc.
That you don't read linked bugs is not my problem, but the initial bug was
filed for wrong_lands_table.doc
Comment 12 rene 2009-07-06 14:05:19 UTC
regression -> target 3.1.1
Comment 13 michael.ruess 2009-07-06 14:30:17 UTC
> Actualkly, I will, because the bug report *was* about wrong_lands_table.doc.
> That you don't read linked bugs is not my problem, but the initial bug was

MRU->rene: So why didn't you mention "wrong_lands_table.doc" in desc1? You only
talked about a.doc there!
Reading linked issues from other system should not be necessary in any case if
you would have posted a correct issue description.

AMA is of course not the correct owner for WW8 import bugs.

I will file a new issue for the "table in RTL context"; this one here is of
course not convenient to read and handle.
Comment 14 michael.ruess 2009-07-06 14:30:41 UTC
closed.
Comment 15 rene 2009-07-06 14:38:47 UTC
> MRU->rene: So why didn't you mention "wrong_lands_table.doc" in desc1? You only
> talked about a.doc there!

Because I referenced the bug. That I  posted a full link has its reason. That is
the canonical place of the initial bug. The rest is just copy/paste and
transcription, and indedd the second comment in theat bug had a.odt in its text.
The initial post said "i will attach the file." - what he did
(wrong_lands_table.doc)

> Reading linked issues from other system should not be necessary in any case if
> you would have posted a correct issue description.

See above. I just pasted what the submitters' said. (And attached their docs).

> I will file a new issue for the "table in RTL context"; this one here is of
> course not convenient to read and handle.

OK. Issue nr I can mark http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=528836
forwarded to?
Comment 16 rene 2009-07-06 14:39:24 UTC
ah, issue 103357