Issue 102090 - OOO310 : problem with setVisible on TextControl
Summary: OOO310 : problem with setVisible on TextControl
Status: CLOSED FIXED
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOO310m9
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: OOo 3.1.1
Assignee: marc.neumann
QA Contact: issues@dba
URL:
Keywords: regression
Depends on:
Blocks: 101565
  Show dependency tree
 
Reported: 2009-05-20 11:18 UTC by dle
Modified: 2009-07-23 19:34 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Test case (12.52 KB, text/plain)
2009-05-20 11:22 UTC, dle
no flags Details
document to reproduce the bug case (9.77 KB, application/vnd.oasis.opendocument.text)
2009-06-05 10:03 UTC, Frank Schönheit
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description dle 2009-05-20 11:18:41 UTC
Since OOO310, if a macro sets the property "Visible" of a text control to False,
this control stays always visible.  
In the attached document, the button switches the property of the text control
to True or False, a message gives the property status.
Comment 1 dle 2009-05-20 11:22:00 UTC
Created attachment 62391 [details]
Test case
Comment 2 jbf.faure 2009-05-21 19:10:37 UTC
Changed number version.
Comment 3 cno 2009-05-27 19:24:10 UTC
confirming the bug
Comment 4 Frank Schönheit 2009-05-27 20:17:43 UTC
form controls belong to DBA
Comment 5 Frank Schönheit 2009-05-27 20:21:31 UTC
Sigh. Tampering with the control's visibility was never an officially supported
feature. Nonetheless, I see that changing a controls visibility is an important
aspect, and unfortunately the most straight-forward way - calling setVisible at
the control - has been used quite often in the wild. Seems the various drawing
layer re-factorings between 3.0 and 3.1 killed that "feature".

I'll wait for a decision from the release team about the target. If the
requested 3.1.1 target is approved, I'll take and fix the issue.

If 3.1.1 is not approved, then I'll close it as WONTFIX, since in 3.2, issue
88878 will be fixed, introducing a "Visible" property at the control *model*,
making visibility changes an official feature then.
Comment 6 bmarcelly 2009-05-28 11:23:49 UTC
Added cc to myself
Comment 7 Frank Schönheit 2009-06-03 20:36:39 UTC
3.1.1 was approved by the release meeting, so grabbing and setting target
milestone accordingly.
Comment 8 Frank Schönheit 2009-06-05 10:03:20 UTC
Created attachment 62791 [details]
document to reproduce the bug case
Comment 9 Frank Schönheit 2009-06-05 10:04:39 UTC
Test_Visible.odt is an extract of the form from Test_Visible.odb, and can be run
in OOo 3.0.x, too (the .odb uses macros in DB docs, which isn't supported in OOo
3.0.x)

Investgating
Comment 10 Frank Schönheit 2009-06-05 10:26:46 UTC
fixed in CWS dba311a

find more information about this CWS, like when it is available in the master
builds, in EIS, the Environment Information System:
http://eis.services.openoffice.org/EIS2/cws.ShowCWS?Path=DEV300%2Fdba311a
Comment 11 Frank Schönheit 2009-06-05 10:27:21 UTC
(note: this was a regression of the drawing layer moving to drawing primitives)
Comment 12 Frank Schönheit 2009-06-24 10:29:51 UTC
fs->msc: please verify in CWS dba311a
Comment 13 marc.neumann 2009-07-01 09:59:16 UTC
verified in CWS dba311a

find more information about this CWS, like when it is available in the master
builds, in EIS, the Environment Information System:
http://eis.services.openoffice.org/EIS2/cws.ShowCWS?Path=DEV300%2Fdba311a
Comment 14 drewjensen.inbox 2009-07-23 19:34:48 UTC
checked w/ OOO310m_16, Ubuntuu 9.04

Closing

NOTE: Opened new issue http://www.openoffice.org/issues/show_bug.cgi?id=103751