Issue 102200 - oowriter freezes on entry of a character from the Supplementary Ideographic Plane
Summary: oowriter freezes on entry of a character from the Supplementary Ideographic P...
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOO310m11
Hardware: PC Linux, all
: P2 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: oooqa
Depends on:
Blocks: 102943
  Show dependency tree
Reported: 2009-05-25 00:08 UTC by echalon
Modified: 2013-01-29 21:47 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

Document where issue can be reproduced (12.26 KB, application/vnd.oasis.opendocument.text)
2009-05-25 21:11 UTC, echalon
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description echalon 2009-05-25 00:08:40 UTC
Steps to reproduce:
1) Open a blank document in Writer
2) Enter two Chinese characters from the Basic Multilingual Plane (U+0000–FFFF),
e.g. "一一" (U+4E00 U+4E00)
3) No issue yet
4) Enter a Chinese character from the Supplementary Ideographic Plane
(U+20000-2FFFF), e.g. "𡃓" (U+210D3)
5) Writer becomes unresponsive and uses 100% of the processor

Basically, paste "一一𡃓" into Writer and it hangs.

I tried a few characters from inside and outside the SIP, and it is only SIP
characters that seem to cause the issue. Also, I can't reproduce the issue with
latin letters as the initial two characters, only Chinese characters from the
BMP. Even three SIP characters in a row seems to be fine. Furthermore, having
the SIP character first, e.g. "𡃓一一" doesn't seem to cause any issue.

I am using OOWriter 3.0.0 in French on Gentoo Linux with kernel 2.6.27.
Comment 1 eric.savary 2009-05-25 15:28:25 UTC
Cannot reproduce on SUNRay in current 310m11.
- Please try the current (3.1rc2) and native (from our site) OOo version.
- Try to find out if this only happens with particular fonts.

Feel free to reopen when you can provide this information
Comment 2 eric.savary 2009-05-25 15:28:41 UTC
Comment 3 echalon 2009-05-25 20:29:36 UTC
- I tried it on OOO310m11 (Build: 9399) from the OOO site in English, and
couldn't reproduce the issue.
- Switching fonts in my original installation didn't prevent the issue, and
using the same fonts in the newer build had no issue.
- Please note that copying 𡃓 from the browser to openoffice may not work
correctly, I use SCIM to input it. It should look like æ’­ with a little box on
the left of it.
Comment 4 eric.savary 2009-05-25 20:41:40 UTC
"- I tried it on OOO310m11 (Build: 9399) from the OOO site in English, and
couldn't reproduce the issue."

So, the issue is fixed?

For the clipboard problem, please file a new issue mentioning the code of the
character copied (U+210D3?), a screenshot of the character in Firefox and in OOo
and mention the font used in OOo.
Comment 5 echalon 2009-05-25 21:11:39 UTC
Created attachment 62514 [details]
Document where issue can be reproduced
Comment 6 echalon 2009-05-25 21:17:05 UTC
I've managed to reproduce the issue with OOO310m11. Steps:
1) Open sip_test.odt (attached)
2) On the third line, replace "o播" with "𡃓".
3) OOWriter hangs.

It's bizarre, because I was able to enter "𡃓" in other places in the document
with no issue, but on that third line between "å¹³" and "ï¼" it hangs every time.

I've tried this with three fonts and had the same issue. I made sure that the
fonts I used all contained this character.
Comment 7 echalon 2009-05-25 21:20:39 UTC
By the way, the OOO310m11 build with which I reproduced this issue was native,
from the OO site.
Comment 8 echalon 2009-05-25 22:36:51 UTC
To avoid possible issues with copy-pasting from the browser, you can copy the
"𡃓" character from inside the sip_test.odt document; it is the second character
on the fourth line.
Comment 9 lohmaier 2009-06-18 12:09:59 UTC
reproducible with the attached document as described. (I used GTK-unicode input
to enter the character)

Occurs with newly created documents as well. Just inserting it somewhere in a
dummy text seems to work OK, without the freeze/100%CPU, but easily reproducible

1) Create new, blank document
2) insert 210d3 followed by two spaces followed by 210d3
→ OOo uses 100% CPU/freezes
Comment 10 echalon 2009-06-18 17:20:44 UTC
cloph, what version did you use when doing the "U+210D3 U+0020 U+0020 U+210D3"
thing? When I tried it in OOO310m11 it didn't break, though that version still
breaks when using the attached document.