Issue 102304 - Hyphenation-dialog doesn't show hyphens anymore
Summary: Hyphenation-dialog doesn't show hyphens anymore
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: DEV300m49
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: stefan.baltzer
QA Contact: issues@sw
URL:
Keywords: regression
: 100273 100853 105795 (view as issue list)
Depends on:
Blocks: 101258 99999
  Show dependency tree
 
Reported: 2009-05-27 14:40 UTC by fredrik.haegg
Modified: 2013-08-07 14:44 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
patch (3.63 KB, patch)
2009-11-09 08:15 UTC, nemeth.lacko
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description fredrik.haegg 2009-05-27 14:40:41 UTC
When using the Hypenation-dialogue, the words are not showed like "foll=ow=ing"
but simply "following", which results in non-functioning arrow-buttons and
thereby makes the whole dialog obsolete.
Comment 1 michael.ruess 2009-07-17 12:47:31 UTC
Can confirm this, worked in 3.1. Dialog is quite useless with this.
Comment 2 stefan.baltzer 2009-10-16 15:51:25 UTC
SBA->TL: This seems to affect English only (tried EN_US, _UK, _ZA, _CAN). 
French, Durch, Italian, German are OK. 
This is a regression and makes the manual hyphenation useless.
Note that automatic hyphenation (Format-Paragraph, Tab "text flow", check
"hyphenation atuomatically") does work.
Comment 3 stefan.baltzer 2009-10-16 16:08:29 UTC
This was OK in OOo 3.0.1, broken in OOo 3.1 and 3.1.1
Comment 4 thomas.lange 2009-10-19 09:56:13 UTC
.
Comment 5 michael.ruess 2009-10-19 11:30:58 UTC
*** Issue 105795 has been marked as a duplicate of this issue. ***
Comment 6 thomas.lange 2009-10-19 14:24:55 UTC
The function hnj_hyphen_hyphenate in lingucomponents hyphenimp.cxx does not find
any possible hyphenations points for English. It works if one copies the
hyphenation file from OOo 3.0.l. 
Thus the hyphenation dictionary content is broken.

The hyphenation file in use for all English variants is hyph_en_GB.dic which is
probably wrong as well since at least for en_US a separate one is available.
However that one is not functional as well.
Comment 7 thomas.lange 2009-10-19 15:19:05 UTC
tl->nemeth: Hi Laccy, if the README_hyph_en_GB.txt and README_hyph_en_US.txt are
correct you have provided us with the hyph_en_US.dic and hyph_en_GB.dic, or more
precisely converted them to the format used in OOo.
Unfortunately those ones seem to be broken. 

They work with automatic hyphenation but not with manual hyphenation which is
very odd.
The hyph_en_GB.dic from OOo 3.0.1 is still functional. Can you have a look at
this and provide it with working ones or drop us a note if we should use the one
from OOo 3.0.1?
Thanks in advance!

Comment 8 nemeth.lacko 2009-10-20 10:01:34 UTC
tl: It seems, the problem is the old hnj_hyphen_hyphenate call and its
incompatibility with the extended hyphenation dictionaries. A question, does the
problematic Hyphenate dialog support alternative hyphenation in StarOffice (eg.
Schiffahrt->Schiff=fahrt in the old German orthography)? If yes, the best is to
fix this problem in OpenOffice.org with Caolan Unicode patch
(http://www.openoffice.org/issues/show_bug.cgi?id=100273). But I will fix it in
the Hyphen library, too.
Comment 9 thomas.lange 2009-10-20 13:44:10 UTC
Adding me to cc.

tl->nemeth: No the dialog does not. It always did only show the original word
with the positions where hyphenation is valid. It never showed any alternative
spellings that would only be printed AFTER the actual hyphenation.
Comment 10 thomas.lange 2009-10-21 08:40:03 UTC
tl->nemeth: In what CWS are you going to fix this?
Currently I have the task added to CWS tl75. But if you are going to fix this in
a different CWS then I will get my CWS ready for QA right away.
Comment 11 thomas.lange 2009-10-21 09:27:40 UTC
.
Comment 12 stefan.baltzer 2009-10-22 14:56:32 UTC
CWS tl75 is ready for QA now without this one.
Because of this issue, some AutoTests are currently not running. The respective
tests shall get re-activated in the same CWS where this issue will get fixed in.
Therefore I put HDE on c/c.
Comment 13 thorsten.ziehm 2009-11-06 08:51:53 UTC
This issue is marked as stopper for OOo 3.2. Do we will get a fix soon?
Comment 14 nemeth.lacko 2009-11-06 11:54:11 UTC
thorstenziehm: I will send the patch at next Monday (extending Caolan's Unicode
patch also with removing the bad alternative hyphenation points for the dialog).
László
Comment 15 nemeth.lacko 2009-11-09 08:15:35 UTC
Created attachment 66007 [details]
patch
Comment 16 nemeth.lacko 2009-11-09 08:31:26 UTC
I have fixed the problem replacing the old hyphen_hyphenate() with the new
hyphen_hyphenate3. With this replacement, there was no need for Caolan's Unicode
patch (only for a small word length fix by replacing encWord.getLength() with
the Unicode nWord.getLength()). Also I had to ignore the special hyphenation
positions with alternations, as in the old hyphen_hyphenate() (see !rep && !rep[i]).
Comment 17 nemeth.lacko 2009-11-09 08:38:58 UTC
nemeth->tl: Thomas, could you add the attached patch to an open CWS? Thanks, László
Comment 18 caolanm 2009-11-09 09:17:36 UTC
*** Issue 100273 has been marked as a duplicate of this issue. ***
Comment 19 thomas.lange 2009-11-10 09:56:12 UTC
tl->nemeth: Ok, I will.

reopening issue.
Comment 20 thomas.lange 2009-11-10 11:35:08 UTC
tl->nemeth: Thanks for the fix!

Patched in CWS fwk125.
Comment 21 thomas.lange 2009-11-11 09:31:20 UTC
.
Comment 22 nemeth.lacko 2009-11-12 06:57:24 UTC
nemeth->tl: Thanks for the quick CWS integration!
Comment 23 helge.delfs 2009-11-12 08:15:52 UTC
HDE: automated test w_hyphenation.bas has been updated to meet changes for this fix
Comment 24 stefan.baltzer 2009-11-19 10:04:15 UTC
Verified in CWS fwk125.
Comment 25 thorsten.ziehm 2009-11-30 14:19:17 UTC
*** Issue 100853 has been marked as a duplicate of this issue. ***
Comment 26 helge.delfs 2010-02-15 12:19:33 UTC
closed due to integration