Issue 102485 - Landscape printing - document printed off centre
Summary: Landscape printing - document printed off centre
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: printing (show other issues)
Version: OOo 3.1
Hardware: Mac Mac OS X, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: h.ilter
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks: 101565
  Show dependency tree
 
Reported: 2009-06-04 03:33 UTC by Larry Gusaas
Modified: 2013-08-07 14:43 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Test file 'test-27.odt' (8.96 KB, application/vnd.oasis.opendocument.text)
2009-06-04 03:40 UTC, Larry Gusaas
no flags Details
Print example 'test-27-print.pdf' (8.50 KB, application/pdf)
2009-06-04 03:42 UTC, Larry Gusaas
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Larry Gusaas 2009-06-04 03:33:16 UTC
When printing a writer document in landscape mode, the page is off centre. It is
shifted 1/8" to the top and 1/8" to the right. A document in portrait mode is
printed properly centred. 

This worked properly in OO.o 3.0.0 and OO.o 3.0.1. I tried it in OO.o 3.1.1
(OOO310m12) and it printed incorrectly. A file exported as a pdf prints
properly. All other applications print properly.

I've attached a test file formatted with .27" margins with borders –
'test-27.odt'. I've also attached a pdf made with "Save as pdf in the Mac print
dialogue to illustrate how the file is printed – 'test-27-print.pdf'.

I'm using:
Macbook Core2 Duo, OS 10.5.7, Canon iP4500 printer.
Comment 1 Larry Gusaas 2009-06-04 03:40:59 UTC
Created attachment 62758 [details]
Test file 'test-27.odt'
Comment 2 Larry Gusaas 2009-06-04 03:42:12 UTC
Created attachment 62759 [details]
Print example 'test-27-print.pdf'
Comment 3 Raphael Bircher 2009-06-10 15:29:07 UTC
Hi

The page format of the attached document is in US Letter, not in DIN A4. If you
print aut the document to a A4 page, then the right page border is bigger. If
you change the page settings to A4 all works well.

So I Set this issue to WORKSFORME
Comment 4 Raphael Bircher 2009-06-10 15:29:42 UTC
closing issue
Comment 5 Larry Gusaas 2009-06-10 19:37:42 UTC
The document is supposed to be US Letter. I use US letter paper, not A4 paper. It should print properly on 
US letter paper. Switching it to A4 is not a solution. Portrait mode prints properly. Previous versions or 
OO.o 3 printed properly.

This is a regression. I am reopening the issue.
Comment 6 Larry Gusaas 2009-06-10 20:11:41 UTC
I just did a further test. I changed the page format to A4. The preview after clicking File/Print shows the 
proper spacing on all four sides. Changing back to US letter and the preview again show page offset to the 
top and to the right.

It seems the problem only occurs with page formatted to US Letter.

I checked further and problem occurs with US Legal as well.
Also occurs with B4(ISO), B5(ISO)

Problem does not occur with A4, A5, A6, C4, C5, C6, C6/5, B6(ISO), B4(JIS).B5(JIS),B6(JIS)
Comment 7 Larry Gusaas 2009-06-11 09:48:38 UTC
I just tested with DEV300_m50. The exists in it as well.

NOTE: In B4(ISO) and B5(ISO) the page prints off -centred to the top and left. In letter and legal it is to the 
top and right.
Comment 8 stefan.baltzer 2009-06-11 10:16:31 UTC
SBA-> HI: Please have a look, thx.
Comment 9 h.ilter 2009-06-11 13:03:59 UTC
When I'm right, your printer is able to print borderless, which has to be
selected before printing. Please test borderless printing.

In general, the border space to the page side at the bottom is higher than
right, left and top.
So when you switch to landscape, the value for bottom is now set to the right side.
This cut effect should appear with all kind of paper which has the same width
like letter format.
Comment 10 Larry Gusaas 2009-06-11 17:40:07 UTC
hi wrote: 
       "Please test borderless printing."
I tested printing borderless. The page is still offset to the top and right. The right side is offset more. 
The borders in my test page have almost no margin before the edge of the page. Top has some margin 
space.

I printed my test page borderless with OO.o 3.0.1 and it printed correctly with equal margins on all 
sides.

       "In general, the border space to the page side at the bottom is higher than right, left and top."
The margins in my test page are the same on all four sides.

       "So when you switch to landscape, the value for bottom is now set to the right side."
Yes. But this is not relevant since all margins are set the same.

"This cut effect should appear with all kind of paper which has the same width
like letter format."
I do not understand what that has to do with the problem
Comment 11 h.ilter 2009-06-19 10:43:28 UTC
Ok, forget my comment before. It occurs in mac only.
Comment 12 da50guy 2009-06-21 15:36:47 UTC
Similar problem with XP. In landscape printing 8.5 x 11, I lose about 1/2 inch
left margin. I haven't noticed a change in the top margin. If there is a change,
it isn't as pronounced.
Comment 13 cno 2009-06-28 08:24:09 UTC
I cannot reproduce in OOo 3.1.0 and DEV300m50 on XP

- start blanc default document
- Format|Page > Landscape
- type "melon and mango"
- print 
  > proper position top/right (2cm from right, 2 cm from top)
Comment 14 noop 2009-06-28 18:07:00 UTC
I cannot reproduce in linux or WinXP:
OOo 3.1.0 buildid=310m11(Build:9399)
Test file 'test-27.odt' 
No setting changes (US letter is default)

For linux I printed to a cups-pdf pdf printer and Canon MP750
For WinXP I printed to PDFCreator pdf printer and CanonMP750
Comment 15 Olaf Felka 2009-06-29 14:24:58 UTC
Setting target and adding to stopper issue
Comment 16 philipp.lohmann 2009-06-30 15:27:28 UTC
fixed in CWS ooo311gsl05
Comment 17 philipp.lohmann 2009-06-30 16:51:35 UTC
fixed
Comment 18 philipp.lohmann 2009-06-30 16:56:49 UTC
please verify in CWS ooo311gsl05
Comment 19 h.ilter 2009-07-03 13:38:42 UTC
Verified with cws ooo311gsl05 = ok
Comment 20 thorsten.ziehm 2010-06-07 11:49:15 UTC
This issue is closed automatically. It is in state 'verified/fixed' since 2
releases (OOo 3.1.1 and OOo 3.2). The policy [1] indicates that such older
issues should be closed.

If this issue still occur in a current build (OOo 3.2.1 or >DEV300m80) please
reopen the issue and set the target accordingly.

[1] : http://wiki.services.openoffice.org/wiki/Handle_fixed_verified_issues