Issue 102628 - WW8: some headings have no outline level on import
Summary: WW8: some headings have no outline level on import
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: formatting (show other issues)
Version: DEV300m49
Hardware: All All
: P3 Trivial (vote)
Target Milestone: 4.1.1
Assignee: openoffice
QA Contact:
URL:
Keywords: ms_interoperability
Depends on: 78498
Blocks: 84405
  Show dependency tree
 
Reported: 2009-06-10 03:02 UTC by amy2008
Modified: 2017-05-20 10:35 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Heading (98.00 KB, application/msword)
2009-06-10 03:05 UTC, amy2008
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description amy2008 2009-06-10 03:02:55 UTC
Can reproduce it in OOo2.4.1 on WinXP and Ubuntu

Open the attachment with OOo, F5 to invoke Navigaotr, check Heading
find no Heading1 and Heading2 under the Heading.

Regards
Li Meiying
Comment 1 amy2008 2009-06-10 03:05:21 UTC
Created attachment 62896 [details]
Heading
Comment 2 cno 2009-06-10 07:21:00 UTC
Hi Li,
The problem is in the document:
When you look at Tools|Outline numbering, you can see that no style is 
associated with Level 1 and Level 2.
Associated with Level 3 is style Heading 3

So this issue as such is invalid.

However, the effect of levels without assiciated headings does occur once in a 
while. That is why I know the problem ;-)
I think it is when you copy paste or import, but am not fully shure.
Maybe there should be an issue about why that happens? But I think some advice 
of a developer on this will be helpful.

What do you think?

Regards,
Cor
Comment 3 redflagzhulihua 2009-06-10 07:48:32 UTC
Hi Cor,

This document is created with MS word by someone we don't know. I don't know
with which version it was created. We created documents with Ms office 2003, and
open it with OOo. All works good. So, by now, we still don't know how it happened.

We know that maybe there is something wrong with the document. But we found
there are many documents of this kind. And MS office can open them correctly.

So we think, consider the interoperability, we need fix it. This will satisfy
the users who have to frequently open MS format documents.

Best regards,
Lihua
Comment 4 cno 2009-06-10 10:04:27 UTC
Hi Lihua,

I fully agree with you, that it is very welcome that this improves!
However, I cannot judge about technical implications, nor to whom such an issue 
should be assigned.
I would guess Henning Brinkman, who works for WW import / export filters.

@sba ??
Comment 5 eric.savary 2009-06-10 22:23:25 UTC
@hbrinkm: please have a look.
Comment 6 Oliver-Rainer Wittmann 2014-07-01 15:29:30 UTC
fixed by changes made for issue 78498