Issue 102756 - cloned template name problem
Summary: cloned template name problem
Status: CLOSED DUPLICATE of issue 68223
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOO310m11
Hardware: PC All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: writerneedsconfirm
QA Contact: issues@sw
URL:
Keywords: needmoreinfo, oooqa
Depends on:
Blocks:
 
Reported: 2009-06-14 02:58 UTC by timdeaton
Modified: 2009-06-21 11:09 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description timdeaton 2009-06-14 02:58:59 UTC
A few days ago I opened an existing Writer template (the actual .ott file in
..\OpenOffice.org\3\User\Template under Application Data), modified it and saved
it to a new name.  Today I couldn't find the new one in the Templates list
(under the "New" icon, then "Templates and Documents), but when I tried to use
the original template, the new one was what appeared.

It turns out that when I gave a new name to the cloned/changed template, that
name change was not made everywhere it should have been.  The "Title" field
shown in the Description tab of the window that appears when you click
|File|Properties| still showed the original template file's name.  And that's
the name that the Templates list (under the "New" icon) displays.

This needs to be fixed so that when you rename a template, that new name is
reflected everywhere.  In fact, it would probably be better if the Templates
list was changed so that it showed the actual filename instead of an internal
"Description" title.
Comment 1 eric.savary 2009-06-14 13:47:33 UTC
Please describe step by step what you have done (each menu click and action)
I cannot reproduce the "I couldn't find the new one in the Templates list".

But I see that the "Title" field contents in fact the file name (without extension).

Thinking about a duplicate of issue 97112
Comment 2 timdeaton 2009-06-18 16:11:12 UTC
The original template is named "ltr.PersTemplate.ott".  It lives at:
c:\Documents and Settings\Tim\Application Data\OpenOffice.org\3\user\template\"

When I decided to create the new template, I navigated to that directory, opened
that .ott file, and then chose |File|Save As| to rename it as a template
filetype to "ltr.PersTemplate5x8.ott" (making sure it got saved in that same
directory).  I then made my changes and saved it again (not 'save as', just 'save').

On the 14th, I started Writer and clicked on the dropdown arrow beside the
NewFile icon (first icon on the left), then chose |Templates and Documents|.  I
immediately knew something was wrong, because the "ltr.PersTemplate5x8.ott"
template name was not in the list.  I then selected the original
"ltr.PersTemplate.ott" template.  But what opened was a new document based on
the "..5x8.." template.

I then navigated back to the directories the two templates live in.  Both files
were still there.  I opened both files and started looking thru the Properties
of both files.  I also used Windows Explorer to check the properties of both files.

What I found was that in both files the "Title" field shown in the Description
tab of the window that appears when you click |File|Properties| still showed the
original template file's name.  (The correct filenames appeared in all other
'Properties' locations I found.)  In the "..5x8.." file, I changed that field to
its proper filename, saved it, and closed both template files.

I then went back to the dropdown arrow beside the NewFile icon, chose |Templates
and Documents| again, and now both templates appeared in the file list.  And
clicking on each name now opened a new doc with the contents of the proper template.

I hope that helps.

It seems unnecessarily complex tho.  In MS Office 97, all I have to do to create
a template is to give it the correct extension and put it in the proper
directory.  MS Office then uses the actual filename, and I don't have to worry
about any internal properties fields.
Comment 3 eric.savary 2009-06-21 11:08:51 UTC
Thank you for the detailed explanation!
This is a dup of issue 68223

*** This issue has been marked as a duplicate of 68223 ***
Comment 4 eric.savary 2009-06-21 11:09:06 UTC
Closed