Issue 102843 - This document has many calculation differeces compared to Excel
Summary: This document has many calculation differeces compared to Excel
Status: CLOSED DUPLICATE of issue 32344
Alias: None
Product: Calc
Classification: Application
Component: programming (show other issues)
Version: OOo 3.0.1
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: spreadsheet
QA Contact: issues@sc
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-16 16:45 UTC by olafurara
Modified: 2009-07-28 12:44 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
The affected file (260.00 KB, application/vnd.ms-excel)
2009-06-16 16:45 UTC, olafurara
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description olafurara 2009-06-16 16:45:03 UTC
The title says it all
Comment 1 olafurara 2009-06-16 16:45:49 UTC
Created attachment 63026 [details]
The affected file
Comment 2 olafurara 2009-06-16 16:48:57 UTC
Gnumeric works
Comment 3 ooo 2009-07-28 12:43:52 UTC
It would help to at least mention what the differences are, what was expected
and what failed, best as "formula in cell ... produces wrong result, should be
... instead". So: sums in row 24 yield 0.

This is because OOo doesn't support the simple wildcards used by Excel, e.g.
"OR*" for strings starting with "OR". OOo uses regular expressions instead.
Switch on Tools->Options->Calc->Calculate "Enable regular expressions in
formulas" and change the filter criteria to "^OR.*"

The request for simple wildcards is handled in another issue.


*** This issue has been marked as a duplicate of 32344 ***
Comment 4 ooo 2009-07-28 12:44:23 UTC
Closing dup.