Issue 102990 - Can't recover chart after deleting one column and UNDO
Summary: Can't recover chart after deleting one column and UNDO
Status: CLOSED DUPLICATE of issue 78849
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: DEV300m50
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: writerneedsconfirm
QA Contact: issues@sw
URL:
Keywords: needmoreinfo, oooqa
Depends on:
Blocks: 84292
  Show dependency tree
 
Reported: 2009-06-22 07:38 UTC by amy2008
Modified: 2009-06-22 11:19 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
original file (12.94 KB, application/vnd.oasis.opendocument.text)
2009-06-22 07:41 UTC, amy2008
no flags Details
Result doc (12.64 KB, application/vnd.oasis.opendocument.text)
2009-06-22 07:42 UTC, amy2008
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description amy2008 2009-06-22 07:38:53 UTC
Can reproduce it in OOo2.4.1 on Windows and Fedora9

How to reproduce it
1 Open a new Writer file
2 Insert a table, like 6*5. Input some data in the table. 
  Insert - Object - Chart, Finish
  In this way, a file like the first attachment will be made.
3 Select a column, like w column, UNDO

Result
Chart can't be recovered

Expectation
Chart recovers successfully

Regards
Li Meiying
Comment 1 amy2008 2009-06-22 07:41:58 UTC
Created attachment 63121 [details]
original file
Comment 2 amy2008 2009-06-22 07:42:49 UTC
Created attachment 63122 [details]
Result doc
Comment 3 eric.savary 2009-06-22 09:01:52 UTC
@amy2008: I think I am missing some things in your description...

You say:

- "2 Insert a table, like 6*5. Input some data in the table. 
  Insert - Object - Chart, Finish"
-> I guess you forgot the step "Select the table" in order to create a CHart
based on the table, right?

- "3 Select a column, like w column, UNDO"
-> I guess you mean:
"3 Select a Data type like "w" in the Chart
4 Delete
5 Go out of the Chart, back to the document"
Right?

In this case, yes, no Undo. You need to re-enter the Chart to undo the data
deletion.

Please comment.
Comment 4 amy2008 2009-06-22 09:17:08 UTC
Meiying to es,

How to reproduce it
1 Open a new Writer file
2 Insert a table, like 6*5. Input some data in the table. set cursor in one cell 
  of the table. 
  Insert - Object - Chart, Finish
  In this way, a file like the first attachment will be made.
3 Select a column, like w column, delete the column, UNDO
Comment 5 eric.savary 2009-06-22 11:19:12 UTC
It's a duplicate of issue 78849.

*** This issue has been marked as a duplicate of 78849 ***
Comment 6 eric.savary 2009-06-22 11:19:29 UTC
Closed