Issue 103133 - embed JDBC driver in ODB files
Summary: embed JDBC driver in ODB files
Status: CLOSED DUPLICATE of issue 60847
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOo 3.1
Hardware: All All
: P3 Trivial with 1 vote (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2009-06-26 12:01 UTC by stlman
Modified: 2017-01-23 18:38 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description stlman 2009-06-26 12:01:41 UTC
It's a great news that macros can be saved in odb files. The next step to create
handy-almost-standalone-db-applications is to embedd JDBC drivers (jar files) in
database files so I, as the one-who-knows, won't have to go to each desktop,
download or copy the jar and add it in the configuration dialog. When I create
an application I can send it to everyone and they can just launch it.
Comment 1 stlman 2009-06-26 12:03:03 UTC
Of course this should be optional and reversible. Anytime I chose to remove or
replace the jar it should be possible.
Comment 2 stlman 2009-07-22 14:57:47 UTC
The problem may me be put more general: embed any jar files. This enables hsql
"stored procedures" to be portable along with  odb files.
Comment 3 stlman 2009-10-01 11:36:01 UTC
Is it a duplicate of bug #60847?
Comment 4 oooforum (fr) 2017-01-23 13:41:54 UTC
According to comment 3

*** This issue has been marked as a duplicate of issue 60847 ***