Issue 103338 - z-index ignored, modified and created wrongly in odt documents.
Summary: z-index ignored, modified and created wrongly in odt documents.
Status: CLOSED DUPLICATE of issue 77355
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOO310m14
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: writerneedsconfirm
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-05 18:29 UTC by frank_markesteijn
Modified: 2009-07-06 11:19 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
text document with an image, path and frame containing text. (170.27 KB, application/vnd.oasis.opendocument.text)
2009-07-05 18:31 UTC, frank_markesteijn
no flags Details
inserted original.odt (167.43 KB, application/vnd.oasis.opendocument.text)
2009-07-05 18:32 UTC, frank_markesteijn
no flags Details
draw objects sorted (188.75 KB, application/vnd.oasis.opendocument.text)
2009-07-05 18:34 UTC, frank_markesteijn
no flags Details
draw objects mixed (188.75 KB, application/vnd.oasis.opendocument.text)
2009-07-05 18:35 UTC, frank_markesteijn
no flags Details
draw objects ordered, z-index stripped (187.39 KB, application/vnd.oasis.opendocument.text)
2009-07-05 18:36 UTC, frank_markesteijn
no flags Details
draw objects mixed, z-index stripped (187.46 KB, application/vnd.oasis.opendocument.text)
2009-07-05 18:37 UTC, frank_markesteijn
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description frank_markesteijn 2009-07-05 18:29:56 UTC
see also: issue 62094, issue 95948

I created a document in Writer, original.odt, containing an image, a path and a
frame with a textbox, when this documents is inserted into another text document
(inserted.odt) then, the image is displayed above all other objects. The order
of creation of the objects is preserved, in contents.xml of inserted.odt, the
image comes first but it's z-index number is not 0, it has the highest number of
all.

To further explore the issue I created four more odt documents (not using
OpenOffice):

in three of the attached documents, z-index-ordered.odt, z-index-mixed.odt and
no-z-index-ordered.odt the picture is displayed above all other objects, it
should be below all others, paths and frames are rendered in the correct order.
The last attached document, no-z-index-mixed.odt, is for comparison, this is
what z-index-mixed.odt would look like if the z-index property were completely
ignored.

About the contents of the attached documents:
z-index-orderd.odt: the draw objects have a draw:z-index property, the value of
which follows the order of creation.
z-index-mixed: a copy of the above file but, the order of the draw objects, as
they appear in content.xml, was mixed up.
no-z-index-ordered: a copy of the first document with all draw:z-index
properties stripped of.
no-z-index-mixed: a copy of the second document with all draw:z-index properties
stripped of.

The first three documents should all look identical when opened in Writer and
indeed they do, but not in the way one would expect, the fourth should show a
different ordering of objects, it does not, after manually deleting the images
from all open documents the rest does look the way it was supposed to.

When you save these four documents, in Writer and under a different name, then
if you unzip these and look in the content.xml files, the order of appearence of
objects is preserved exept for the image, that is allway put first, the z-index
numbers follow the order of appearance but, the image receives the largest
number, in other words it is a mess.

These four documents were not created with OpenOffice but, as far as I can tell
they do conform to the ODF specification, iso/iec 26300 and the image is fine
too, a PNG image with indexed colours. If anyone knows of a workaround, what
changes to make to the xml code, that would be nice, it may offer me some
solice, perhaps a way off the workaroundabout.
Comment 1 frank_markesteijn 2009-07-05 18:31:38 UTC
Created attachment 63374 [details]
text document with an image, path and frame containing text.
Comment 2 frank_markesteijn 2009-07-05 18:32:38 UTC
Created attachment 63375 [details]
inserted original.odt
Comment 3 frank_markesteijn 2009-07-05 18:34:23 UTC
Created attachment 63376 [details]
draw objects sorted
Comment 4 frank_markesteijn 2009-07-05 18:35:33 UTC
Created attachment 63377 [details]
draw objects mixed
Comment 5 frank_markesteijn 2009-07-05 18:36:32 UTC
Created attachment 63378 [details]
draw objects ordered, z-index stripped
Comment 6 frank_markesteijn 2009-07-05 18:37:30 UTC
Created attachment 63379 [details]
draw objects mixed, z-index stripped
Comment 7 frank_markesteijn 2009-07-05 20:36:19 UTC
See also issue 103339
Comment 8 michael.ruess 2009-07-06 11:18:21 UTC
Already tracked as issue 77355.

*** This issue has been marked as a duplicate of 77355 ***
Comment 9 michael.ruess 2009-07-06 11:19:09 UTC
Closing duplicate.