Issue 103347 - When drilling into a data pilot cell in the data range, calc crash
Summary: When drilling into a data pilot cell in the data range, calc crash
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: Calc
Classification: Application
Component: code (show other issues)
Version: OOO310m11
Hardware: PC Linux, all
: P3 Trivial (vote)
Target Milestone: 3.4.0
Assignee: spreadsheet
QA Contact: issues@sc
URL:
Keywords:
: 108036 108396 (view as issue list)
Depends on:
Blocks:
 
Reported: 2009-07-06 10:26 UTC by rmano
Modified: 2013-08-23 14:35 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Simple data pilot example (10.74 KB, application/vnd.oasis.opendocument.spreadsheet)
2009-07-06 10:31 UTC, rmano
no flags Details
Data Recovery window displayed after double-click (11.47 KB, image/png)
2010-01-22 07:26 UTC, robbk
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description rmano 2009-07-06 10:26:52 UTC
Using build 9399 of OO 3.1.0, as packaged for Ubuntu Intrepid Ibex, package 
 1:3.1.0-5ubuntu1~intrepid1.

If I try to double click on a cell into a DataPilot-generated range, Calc crash
hard. Will attach a minimal file showing the problem.
Comment 1 rmano 2009-07-06 10:31:49 UTC
Created attachment 63390 [details]
Simple data pilot example
Comment 2 kyoshida 2009-07-06 18:55:37 UTC
Debian had the same issue, and it turned out to be an issue with the version of
stlport Debian (and probably Ubuntu) ships with.

BTW, before anybody jumps in, this is not an issue with go-oo.
Comment 3 kpalagin 2009-07-08 14:30:39 UTC
m49 on WinXP does not crash.
Linux only?

rmano,
please try using Sun build of OO and see if it crashes too.
Comment 4 rmano 2009-07-08 14:36:08 UTC
Is there a way I can test it without having to destroy my installation? A livecd
maybe which come with it that i can start in a virtual machine? 

Comment 5 Regina Henschel 2010-01-02 19:05:43 UTC
Hi rmano, please have a look at
http://wiki.services.openoffice.org/wiki/Run_OOo_versions_parallel
section 1.2
Comment 6 Raphael Bircher 2010-01-03 17:33:34 UTC
*** Issue 108036 has been marked as a duplicate of this issue. ***
Comment 7 kyoshida 2010-01-19 03:21:50 UTC
*** Issue 108396 has been marked as a duplicate of this issue. ***
Comment 8 robbk 2010-01-22 07:25:35 UTC
Confirmed on WinXP, OOO310m11 Build 9399 Novell edition.
- Downloaded the attached file oocalc_dp_crash.ods.
- Double-clicked in a cell in the DataPilot.
- Document Recovery window was displayed. Will attach screenshot.
Comment 9 robbk 2010-01-22 07:26:55 UTC
Created attachment 67354 [details]
Data Recovery window displayed after double-click
Comment 10 tml 2010-01-25 11:42:33 UTC
I can reproduce the crash with Novell Edition builds 3.1-9 and 3.1.1-4 on Windows.

(robbk: "OOO310m11 Build 9399" doesn't really say anything more than just "3.1"
does. Both "OOO310m11" and "Build:9399" are one-to-one equivalent with the
official source release of "3.1" and just identify the upstream source version.
Yes, this is silly redundancy and misleading use of the word "build". The way to
*really* identify an *actual* build of the Novell Edition is either by including
the number after the dash in the name of the installer or zip file, or
mentioning the build date indicated at the bottom of the Help:About box.)
Comment 11 robbk 2010-01-25 12:19:27 UTC
"Build 2009-05-27"
Too bad one can't copy and paste this info from the "About OpenOffice.org" window.
Comment 12 kyoshida 2010-01-25 19:25:16 UTC
confirming
Comment 13 kyoshida 2010-01-25 19:30:33 UTC
There are two separate crash cases reported wrt datapilot wrt the go-oo and
novell edition here.  One is the crash when double-clicking on a field name, and
the other is the crash when double-clicking on a data cell.  They have different
root causes.  I just fixed the issue for the former crash case in the go-oo as
well as the novell edition.  The latter case (crash on the data cells) was what
I referred to earlier in this report, and I don't know if it's still there or
not, as I was never personally able to reproduce it in my environment.

I'll just handle the former crash case in this bug report, which is also
upstream relevant with the integration of koheidatapilot03.
Comment 14 kyoshida 2010-01-25 19:31:43 UTC
started.
Comment 15 robbk 2010-01-26 06:09:08 UTC
I reported a crash when double-clicking in a data cell, as I think did the
original poster. I don't see any mention of field names.
Comment 16 kyoshida 2010-01-29 19:02:22 UTC
changing the title to make it clear, and back to spreadsheet ownership for the
time being.
Comment 17 oc 2010-09-23 12:44:04 UTC
could not be reproduced in current build OOo330m8
=>kohei: please verify if this happens on go_ooo
Comment 18 Mechtilde 2010-10-17 08:03:46 UTC
worksforme -> closed
Comment 19 Edwin Sharp 2013-08-23 14:35:24 UTC
*** Issue 108036 has been marked as a duplicate of this issue. ***