Issue 103546 - Zoom slider in Draw too sensitive
Summary: Zoom slider in Draw too sensitive
Status: CLOSED DUPLICATE of issue 102674
Alias: None
Product: Draw
Classification: Application
Component: code (show other issues)
Version: OOo 3.1
Hardware: Unknown All
: P3 Trivial with 3 votes (vote)
Target Milestone: ---
Assignee: groucho266
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-14 16:51 UTC by Mathias_Bauer
Modified: 2017-05-20 09:59 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Mathias_Bauer 2009-07-14 16:51:01 UTC
If the zoom slider is at 100%, every move to the right immediately jumps to
several hundred percent. It is barely usable that way.
Comment 1 Mathias_Bauer 2009-07-14 16:51:31 UTC
Target 3.x
Comment 2 jbf.faure 2009-09-12 19:01:54 UTC
Same problem in Impress of course.
The maximum of zoom factor is around 3000% (600% in writer). If you have the bad
idea to try it, OOo has to work hard to update the view and OOo is not usable
during a too long time (around 1 minute for me).

Kind regards.
JBF
Comment 3 Luke.A.Somers 2013-05-30 23:42:22 UTC
This would be much less of a big deal if the Zoom... menu item had a keyboard command (I was able to set one up via the system's "keyboard" control panel, but still)

As it stands... wow.
Comment 4 Armin Le Grand 2013-05-31 13:03:43 UTC
ALG: I was irritated by what 'move to the right' means, it applies to the zoom slider itself. When grepping the zoom slider button indeed the useful area is small, due to the fact that the whole possible zoom range is shown. I see not really an alternative, though (except making the slider wider?)
Comment 5 Luke.A.Somers 2013-05-31 13:11:37 UTC
(In reply to Armin Le Grand from comment #4)
> ALG: I was irritated by what 'move to the right' means, it applies to the
> zoom slider itself. When grepping the zoom slider button indeed the useful
> area is small, due to the fact that the whole possible zoom range is shown.
> I see not really an alternative, though (except making the slider wider?)

No, all you need is to shift to a log scale so each pixel corresponds to a different factor in scale. As it stands, it's linear with abrupt changes of slope at the lines - there is a huge difference across the 100% line.

Dragging the minimum amount to the left of 100% yields 88%. Very nice, nearly continuous. Dragging the minimum amount to the right of 100% yields 335%. This is... not.

One very cheap solution would be to go to log scale. With a log scale, you would still have access to the very high zoom levels, but not at such tiny increments. The saved screen space would go to lower zoom levels.



Another would be turn off the snap-to behavior if you're holding shift, like how holding shift turns off the angle constraints on drawing lines. Or if you simply held the mouse in place for a second, it would figure you meant 'right here'
Comment 6 oooforum (fr) 2015-02-16 11:15:35 UTC
Please, report your votes

*** This issue has been marked as a duplicate of issue 102674 ***