Issue 104045 - Filtering is unacceptably slow
Summary: Filtering is unacceptably slow
Alias: None
Product: Calc
Classification: Application
Component: viewing (show other issues)
Version: OOo 3.1
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: performance
Depends on:
Reported: 2009-08-06 09:37 UTC by kpalagin
Modified: 2017-05-20 11:11 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

problematic file (272.00 KB, application/vnd.oasis.opendocument.spreadsheet)
2009-08-06 09:39 UTC, kpalagin
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description kpalagin 2009-08-06 09:37:56 UTC
In attached file please try selecting any valu in filter for Name column - it
takes couple of minutes to display the result on P4-2.4. This makes filter
unsuable for this file.
We also have, but file
for this issue does not seem to have many styles and solution - copy-paste plain
text does not fix the problem.
Comment 1 kpalagin 2009-08-06 09:39:36 UTC
Created attachment 63981 [details]
problematic file
Comment 2 kpalagin 2009-09-10 07:24:07 UTC
please consider this issue as it makes OO unusable for this file.
Thanks a lot for your attention.
Comment 3 oc 2009-09-10 08:56:19 UTC
maybe something for the performance project?
Comment 4 bcsi 2010-06-28 14:25:24 UTC
Have you tried the the document under 3.0? I have a customer with a similar
problem. He upgraded to 3.1 to get the docx functionality but when he was
working on this one calc document with filters it took anywhere from 5 to 15
seconds when using the filters where previously under 3.0 it was instantaneous.
We later tried 3.2 with the same results. We ended up removing OO and
reinstalling 3.0. He's happy again.

For the docx isue I installed wordview.

Hope this helps a bit.
Comment 5 ooo 2010-08-26 14:06:23 UTC
Won't have time to work on this for OOo3.3, re-targeting to OOo3.4
Comment 6 Martin Hollmichel 2011-03-15 12:51:01 UTC
set target to 3.x since not release relevant for 3.4.
Comment 7 Marcus 2017-05-20 11:11:48 UTC
Reset assigne to the default "".