Issue 104318 - Copy/paste of TIME fields from Calc to Base fails
Summary: Copy/paste of TIME fields from Calc to Base fails
Status: CLOSED NOT_AN_OOO_ISSUE
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOO300m9
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact: gg43
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-18 15:59 UTC by comtinux
Modified: 2017-05-20 09:35 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: 4.1.0
Developer Difficulty: ---


Attachments
File ,odb and file .ods used in my test (10.08 KB, application/x-zip-compressed)
2013-03-11 23:00 UTC, gg43
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description comtinux 2009-08-18 15:59:08 UTC
Having the following configuration:
- 1 "input" .ods file containing data to import into the database, with the
form: 1st line contains .odb's table T column headers, and next lines contain data
- 1 "output" .odb file connected to a PostgreSQL 8.3 ODBC datasource with
read+write rights on a given table T

The import method used between Calc and Base is :
- copy selected data from Calc (header+data lines)
- paste in Base by applying it on table T, and then by completing Base's "paste
wizard"

The problem: 
Any Calc cell with type TIME (e.g. 12:34:56) is pasted in Base column with SQL
type TIME as 00:00:00. Whatever the content of the input Calc cell is.
This problem occurs with no particular error or warning message, giving the user
the impression that the paste from Calc into Base is ok.

What is expected:
The content of Base columns with type TIME should be pasted with values coming
from the copied Calc "TIME" cells, not 00:00:00.
Comment 1 Frank Schönheit 2009-08-31 11:13:06 UTC
note: this might be a duplicate of issue 103882, which I expect to be fixed in
developer snapshot DEV300.m58
Comment 2 gg43 2013-03-11 23:00:26 UTC
Created attachment 80390 [details]
File ,odb and file .ods used in my test

Platform: 
Operating System: Windows 7 Home Premium Version 6.1.7601 Service Pack 1 Build 7601 (x64)
Apache Open Office 3.4.1 AOO341m1 Build 9593 Rev 1372282

I attach the file used to test
I performed the actions suggested by comtinux and I got the same fault reported.
Comment 3 gg43 2013-03-11 23:04:02 UTC
Set 
status to CONFIRMED
importance to normal
Comment 4 gg43 2014-08-09 21:00:26 UTC
Platform: 
Operating System: Windows 7 Home Premium Version 6.1.7601 Service Pack 1 Build 7601 (x64)
Apache Open Office 4.1.0 AOO410m18(Build:9764)  -  Rev. 1589052

I repeated the test with Open Office 4,1,0 and thanks to the error messages in the process of entering data into the base table, I found that the columns date, time and timestamp in spreadsheet table were text.

I then corrected the data in columns in Calc with type date, time and timestamp so it was possible to copy and paste data correctly in a table in Open Office Base

Therefore set State to RESOLVED / FIXED
Comment 5 Kay 2016-03-21 22:28:06 UTC
Changing to NOT_AN_ISSUE as opposed to FIXED based on comments. Leaving open in case there is more discussion.