Issue 104495 - KDE4 integration - please make available for standard OOo build
Summary: KDE4 integration - please make available for standard OOo build
Status: RESOLVED FIXED
Alias: None
Product: Build Tools
Classification: Code
Component: solenv (show other issues)
Version: DEV300m55
Hardware: All Unix, all
: P3 Trivial with 6 votes (vote)
Target Milestone: 4.1.8
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on: 109357
Blocks:
  Show dependency tree
 
Reported: 2009-08-25 14:14 UTC by philipp.lohmann
Modified: 2020-08-27 16:31 UTC (History)
9 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
patch removing libstdc++ and libgcc_s from the install set (1.01 KB, patch)
2010-06-30 17:04 UTC, philipp.lohmann
no flags Details | Diff
updated patch for DEV300_m90 (3.69 KB, patch)
2010-10-27 14:56 UTC, philipp.lohmann
no flags Details | Diff
enhanced version (9.93 KB, patch)
2010-10-28 17:47 UTC, philipp.lohmann
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description philipp.lohmann 2009-08-25 14:14:29 UTC
Since integration of CWS kde4int there is support for KDE4 integration
available, currently only with configure --enable-kde4. Please consider making
this available in the standard build. Setting tentative 3.3 target since you
mentioned your workload does not permit 3.2.
Comment 1 Martin Hollmichel 2009-08-31 10:53:25 UTC
reassign to myself
Comment 2 Ariel Constenla-Haile 2009-09-18 16:19:45 UTC
.
Comment 3 andreschnabel 2009-09-26 14:20:38 UTC
hi - what is the status of this issue? DEV300m60 as no active kDE4 support, what
is in fact a regression from a user's pov.

OOo 3.1.1 did use QT (maybe because kde3 libs were still installed). DEV300m60
uses plain VLC rendering for the UI.
Comment 4 Ariel Constenla-Haile 2009-09-26 17:10:58 UTC
@andreschnabel : If your system has KDE 3 libs (distros still privide KDE3
because some portings are not mature enough), you can force OOo to use the KDE3
vcl plug-in; see http://arielch.wordpress.com/2009/09/06/where-has-kde-gone-in-
Comment 5 andreschnabel 2009-09-26 18:11:37 UTC
@arielch: I'm aware of this workaround. but still - for a regular user it is a
regression.
Comment 6 philipp.lohmann 2009-10-21 17:37:19 UTC
Should there indeed be an integration into the standard build for 3.2 I'd
recommend taking also these changesets into account:

http://hg.services.openoffice.org/hg/cws/vcl106/rev/e6e8beb9d8ec
http://hg.services.openoffice.org/hg/cws/vcl106/rev/a56166221f22

which fix issues 106113 and 105152 respectively.
Comment 7 rt 2009-11-06 07:31:20 UTC
Can't see this enhancement as stopper for 3.2 -> next release
Comment 8 rgb 2009-11-06 12:58:08 UTC
>> Can't see this enhancement as stopper for 3.2 -> next release
Ok, we all agree it is not a stopper but, why it is necessary to delay a _config
option_ more than 6 months? Is there another problem? If yes, can you please
share it? 
For the "common Linux user" knowing that the code is there and only need a flag
to be used but will not be used for another half year sounds quite strange...
Comment 9 rt 2009-11-06 13:29:11 UTC
This issue is not about making KDE4 integration possible, it is about enabling
this option in standard SUN OOo builds. For these builds we use a common
environment to ensure standard, reproducible, baseline compatible builds even on
non baseline computers. So, basically this issue is about bringing kde4 into
that environment. Without breaking the environment for older workspaces. That's
no rocket sience, but some amount of work, and has to be done and tested with care.
Comment 10 rgb 2009-11-06 15:43:16 UTC
Perfectly clear. Thanks!
Comment 11 philipp.lohmann 2010-06-04 10:34:57 UTC
ping ? We seem to have a new baseline now, so shouldn't that enable us to
provide the KDE4 plugin ?
Comment 12 philipp.lohmann 2010-06-30 17:03:30 UTC
I have provided the necessary headers and libraries in our build environment for
both linux x86_32 as well as x86_64, the CWS enabling this is kde4enable. Our
very own build machine for x86_64 is getting updated to the current glibc2.5
baseline currently, so there should be no problems in principle.

Unfortunately the installed OOo hits a problem: since our builds install their
own libstdc++ and libgcc_s the system's kde libs hit that libstdc++.so.6 when
the KDE4 plugin gets loaded. Our libstdc++ however is too old and misses a
symbol e.g. on OpenSuSE 11.2. Removing our own libstdc++ from
<office>/openoffice.org/ure/lib/ solves the problem.

However both not delivering a libstdc++/libgcc_s anymore as well as upgrading
libstdc++ would be a baseline change.

@mh: This is something I would want to leave in your capable hands. I'll change
ownership of kde4enable to you. I'll also attach a patch that would not install
libstdc++.so.6 and libgcc_s anymore relying on the system version (that seems to
be the most sensible solution for me). Either that patch would need to be added
to kde4enable or libstdc++ would need to be updated in that CWS before integration.
Comment 13 philipp.lohmann 2010-06-30 17:04:32 UTC
Created attachment 70322 [details]
patch removing libstdc++ and libgcc_s from the install set
Comment 14 Stephan Bergmann 2010-07-01 08:10:35 UTC
just for completeness: the attached ure.scp.diff (if ever used) should also
update information about libstdc++.so.6 and libgcc_s.so.1 in ure/source/README,
ure/source/uretest/README, ure/source/uretest/Makefile, and
ure/source/uretest/Makefile.pln
Comment 15 philipp.lohmann 2010-10-27 14:56:00 UTC
Created attachment 72754 [details]
updated patch for DEV300_m90
Comment 16 philipp.lohmann 2010-10-27 14:56:46 UTC
the attached patch now contains the changes mentioned by sb
Comment 17 Stephan Bergmann 2010-10-27 16:02:06 UTC
@pl, re the attached ure.scp.2.diff:

- If the URE package no longer contains libgcc_s.so.1 and libstdc++.so.6, should
it instead have a dependency on those libraries within the system (however such
a dependency is expressed in the various package formats)?

- Are the remaining occurrences of SHORTSTDC3 and SHORTSTDCPP3 in
external/gcc3_specific/makefile.mk, solenv/inc/settings.mk,
solenv/inc/tg_compv.mk, and solenv/inc/target.mk still needed?

- Dangling references of gid_File_Dl_GccS and gid_File_Dl_Stdcpp should be
removed from scp2/source/ooo/ure.scp.

- *All* occurrences of GCCS_COMPAT should be removed from
ure/source/uretest/Makefile, ure/source/uretest/Makefile.pln, and
ure/source/uretest/README.

- Typo "prcise" in ure/source/README.
Comment 18 philipp.lohmann 2010-10-28 17:47:33 UTC
Created attachment 72772 [details]
enhanced version
Comment 19 philipp.lohmann 2010-10-28 17:49:07 UTC
attached a version of the patch including sb's very valid points. Additionally a
"hg remove external/gcc3_specific" should be done when applying the patch.
Comment 20 philipp.lohmann 2011-01-18 09:46:58 UTC
May I ask why the 3.x target and not 3.4 ?
Comment 21 SVN Robot 2017-01-16 22:25:09 UTC
"pfg" committed SVN revision 1779119 into trunk:
i104495 - libstdc++ removal.
Comment 22 Marcus 2017-05-20 11:05:12 UTC
Reset assigne to the default "issues@openoffice.apache.org".
Comment 23 Matthias Seidel 2020-08-27 16:31:51 UTC
Cherry-picked for AOO 4.1.8 with:

https://github.com/apache/openoffice/commit/07cb168e39e3222dcab8b8ce75d6fed4c00ec170