Issue 104508 - OOo Looping on KDE when adding item to recent document list on file reload
Summary: OOo Looping on KDE when adding item to recent document list on file reload
Status: CLOSED FIXED
Alias: None
Product: QA
Classification: Unclassified
Component: testscripts (show other issues)
Version: DEV300m53
Hardware: All Linux, all
: P2 Trivial
Target Milestone: ---
Assignee: b.osi.ooo
QA Contact: issues@qa
URL:
Keywords:
Depends on:
Blocks: 99999
  Show dependency tree
 
Reported: 2009-08-26 00:10 UTC by eric.savary
Modified: 2013-08-07 15:07 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description eric.savary 2009-08-26 00:10:44 UTC
m_updt.bas breaks in tmFileReload

As seen in CWS sw32a11y01, otf01 and bjm02 (resp. m54, m55 and m53).
This error is not reproducible when running only the test case or even 12 test
cases before it but always when running the whole test.

Seen on a qabot (from EIS) and qa template vm-es2.
Comment 1 b.osi.ooo 2009-08-26 13:31:17 UTC
indeed - started
Comment 2 b.osi.ooo 2009-09-03 14:13:32 UTC
Nailed culprint down so far to:
tToolsOptionsDatasources
tmFileReload

I remember slightly some crash around that area, but no looping....further
investigating...
Comment 3 b.osi.ooo 2009-09-03 14:33:03 UTC
Manual reproducing on linux (vm available on request) with:
- quit OOo
- delete user layer/settings directory
- start soffice - start center comes up
- open: tools->options->StarOffice Base: select tabpage:  'Connections' or
'Databases'
- cancel dialog with 'cancel'
- open File->new->Formula (or writer, or....(I have not tried further))
- type: a
- save
- reload
-> loop
Comment 4 b.osi.ooo 2009-09-03 14:41:40 UTC
guessing culprint in base: fs, your turn.
One thing I would try again with: a build, where the issue is fixed, that OOo
crashes on closing, after base was used. Any hint in which CWS/build that was fixed?
Comment 5 Frank Schönheit 2009-09-08 21:29:08 UTC
fs->tbo: Cannot reproduce, neither in m53 nor in m57. At least this holds for
the manual description you gave above, I have to give testtool a try ...
Comment 6 Frank Schönheit 2009-09-09 12:27:26 UTC
fs->pl: That's a problem with shell/source/unix/sysshell/systemshell.cxx, and
you're closes to what I would call an owner of this code, so ...

First, the scenario described by TBO above works, but not on every machine. I
needed to use a virtual machine he provided to reproduce the problem.
Second, removing the user layer is not necessary, I could reliably reproduce it
without that.

Third, on the mentioned virtual machine, OOo is running on a KDE desktop. Now
when the file is reloaded, then SFX calls SystemShell::AddToRecentDocumentList,
which in turn calls gtk_recent_manager_add_item, and never returns from there.

On the console where you started OOo, the following output appears:

(process:23850): GLib-GObject-CRITICAL **: gtype.c:2248: initialization
assertion failed, use IA__g_type_init() prior to this function

(process:23850): GLib-CRITICAL **: g_once_init_leave: assertion
`initialization_value != 0' failed

(process:23850): GLib-GObject-CRITICAL **: g_object_new: assertion
`G_TYPE_IS_OBJECT (object_type)' failed

Googling for gtypec:2248 leads to (e.g.) http://bugs.archlinux.org/task/10740,
where there is an interesting comment saying "The problem is that OpenOffice
tries to detect a GTK environment and starts using GTK features even when GTK
isn't initialized, resulting in critical assertions and hanging applications."

Sounds like systemshell.cxx misses some call to gtk_init_check ...?
Comment 7 philipp.lohmann 2009-09-09 13:36:43 UTC
pl->cmc: I think you wanted to move that code into the vcl plugin anyway; how
far along is that ? I think that would be the real fix for this problem. Would
you be interested in moving that into 3.2 ?
Comment 8 caolanm 2009-09-09 13:50:12 UTC
cmc->pl: Its moved in cmcfixes62 which was *intended* for 3.2 and works fine for
me under linux. But the build-bot situation is ludicrous at the moment with 90+
hour wait times so its impossible for me to generate a windows install set to
verify that it works under windows.
Comment 9 caolanm 2009-09-09 13:53:04 UTC
i.e. 104306
Comment 10 philipp.lohmann 2009-09-09 14:06:55 UTC
Interesting. May be a little selfish then and add this issue to cmcfixes62 ? I'd
fetch that one and build local install sets for tbo to play with, who would then
probably also be the QA rep ?
Comment 11 philipp.lohmann 2009-09-09 14:08:32 UTC
Ah, you already have a QArep, so we don't need another I guess.
Comment 12 caolanm 2009-09-09 14:18:51 UTC
"...add this issue to cmcfixes62. I'd fetch that one and build local install
sets for tbo to play with, who would then probably also be the QA rep ?"

Go for it, that would be ideal from my pov. dtardon is my co-worker, so changing
to tbo would work better for us given the cross-platform issues in this ws.
Comment 13 philipp.lohmann 2009-09-09 14:24:15 UTC
Great ! Thanks. I'll also port the fix for issue 104525 which is now in a dead
file I presume.
Comment 14 caolanm 2009-09-09 14:33:04 UTC
You'll find the macosx bit moved into aqua/app/salinst.cxx
Comment 15 b.osi.ooo 2009-09-09 15:03:02 UTC
Changing summary from '[Automation] m_updt.bas breaks in tmFileReload' to the
actual problem:
'OOo Looping on KDE when adding item to recent document list on file reload'
Comment 16 philipp.lohmann 2009-09-09 19:12:25 UTC
fixed by cmc in CWS cmcfixes62
Comment 17 philipp.lohmann 2009-09-09 19:13:04 UTC
please verify in CWS cmcfixes62
Comment 18 b.osi.ooo 2009-09-14 16:31:50 UTC
Verified on linux in CWS cmcfixes62
Comment 19 b.osi.ooo 2009-10-06 13:44:54 UTC
closing as integrated into master