Issue 104659 - Some cells are displaying ”Err: 522” in Full screen mode
Summary: Some cells are displaying ”Err: 522” in Full screen mode
Status: CONFIRMED
Alias: None
Product: Calc
Classification: Application
Component: ui (show other issues)
Version: OOo 3.1
Hardware: PC All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-31 17:49 UTC by guraknugen
Modified: 2013-01-29 21:49 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
An example of a file where the problem occurs. (244.98 KB, application/vnd.oasis.opendocument.spreadsheet)
2009-08-31 17:51 UTC, guraknugen
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description guraknugen 2009-08-31 17:49:29 UTC
I have a kind of medium complicated spreadsheet that I usually use in full 
screen, because I mainly use it on an Eee PC 900 (which screen resolution is 
1024×600). I have tested the spreadsheet on a bigger laptop as well, and I get 
exactly the same symptoms.

As long as I don't use the full screen mode, everything works perfectly. If I 
switch to full screen mode, some cells some times display Err: 522. If I do a 
hard recalculation, all cells display their correct values.

The ”Err: 522 cells” are not very complicated. It's an IF statement and inside 
it a COUNTIF() function. A few of the ”Err: 522 cells” contain nothing more 
than a SUM() function.

There are quite a few cells that some times, after entering a value in a cell, 
turns to Err: 522, but it doesn't happen for every cell every time. Sometimes 
no cells turns Err: 522 and sometimes several cells do.

Whenever it happens, though, hard recalculation always helps, which I think 
indicates that there isn't anything wrong with my cell formulae. There is no 
circular reference what so ever, I can promise you that. And if it was, hard 
recalculation wouldn't help, would it?

One of the machines runs Ubuntu 8.10 and the other one Ubuntu 9.04. I am not 
sure if this happens on other operating systems, since I don't have other 
operating systems…

Well, I remember that I had the same problem when I had Mandriva Linux Free 
2009.0 and 2009.1 on that Eee PC, and that was with OpenOffice.org 3.0.1, not 
3.1.0. The same thing also happens with OpenOffice.org 3.0.1 on Ubuntu 9.04. 
Maybe the operating system doesn't have anything to do with this…

I'll include the file that made me see the problem. It contains some unfinished 
Macros (”work in progress”…), but you don't need them for this test anyway. 
Just select the sheet ”Spelblad” (the second one from the left), enter some 
numbers in the unprotected cells (most of the white ones with a few 
exceptions). Do this in full screen mode and also do it in normal mode. As far 
as I have seen, the Err: 522 NEVER shows up at normal mode, but it happens 
quite often in full screen mode.

Thanks.
Comment 1 guraknugen 2009-08-31 17:51:42 UTC
Created attachment 64460 [details]
An example of a file where the problem occurs.
Comment 2 Stefan Weigel 2009-09-01 14:10:57 UTC
Confirming. Tested with OOO 3.1.1 (OOO310m19) on Win2000. 
Comment 3 Joe Smith 2010-10-12 16:03:08 UTC
Is this different from Issue 76756 ?