Issue 104662 - [CWS printerpullpages] Different behavior for "reverse page order" required?
Summary: [CWS printerpullpages] Different behavior for "reverse page order" required?
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: current
Hardware: All All
: P3 Trivial (vote)
Target Milestone: OOo 3.3
Assignee: christoph
QA Contact: issues@framework
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-31 20:15 UTC by christoph
Modified: 2017-05-20 10:28 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description christoph 2009-08-31 20:15:05 UTC
The current printer dialog rework adds N-up printing for system independent
printing dialogs. This may affect the printing option "reverse page order".

BEHAVIOR
Current behavior: Reverse page order does - as the name implies - reverse the
page order. This behavior was okay before N-up printing was implemented since
there were only paper sheets with one page.

Proposed behavior: Reverse page order should affect the paper stack and not only
the page range. The naming may be changed (see below).


NAMING
Naming will be discussed on a separate page (link) below. For the sake of
completeness... Comments by Regina 15:03, 25 August 2009 (UTC):
<<On Writer, Tab "Options" there is the checkbox "Reverse page order". It should
be "Reverse paper sheet order". Reasons: The option is needed for manual duplex
printing and is not only applied to normal print but also to brochure printing.
...>>
http://wiki.services.openoffice.org/wiki/Printerpullpages/String_Reviews

POTENTIAL NAMING ISSUE
N-up is only available in the system independent printing dialog --> in native
printing dialogs N-up is most presumably realized by the operating system -->
may have impact on the naming (pages vs. paper sheets)
Comment 1 Regina Henschel 2009-08-31 22:30:33 UTC
The option 'left pages' and 'right pages' cannot be disabled in the print
dialog, which you get in OOo3.1, when you print in Writer from inside page view.
(That is the OOo3.1 place to define a N-Up printing layout.) So in the actual
version OOo3.1 manual duplex printing by even/odd selecting cannot be combined
with N-Up printing layout. Therefore it would be no regression to disable
front/back selecting for N-Up in printerpullpages until a clean solution is found.

In OOo3.1 'reverse order' is possible in N-Up. There it has the meaning of
reverse document pages. You notice it, when printing a 7 page document in '1row
x 2column' layout. You get the paper sheets 6/7, 4/5, 2/3, 1/empty, whereas a
reverse paper sheet stack would lead to 7/empty, 5/6, 3/4, 1/2. If your number
of pages is a multiple of the number of paper sheets, it makes no difference. 

Because manual duplex printing is not possible at all, I don't know a use case
for 'reverse page order' in that OOo3.1 dialog.

If you disable or change the behavior of reverse order or front/back selecting
for N-up, please make sure, that it works for brochure printing, where these
settings are essential for manual duplex printing. 

Comment 2 philipp.lohmann 2009-09-08 17:41:36 UTC
confirm
Comment 3 philipp.lohmann 2009-09-08 17:42:41 UTC
reverse print affects sheets now not document page order; difference only in
N-Up with n != 1

fixed in CWS printerpullpages
Comment 4 philipp.lohmann 2009-10-26 13:24:49 UTC
please verify in CWS printerpullpages
Comment 5 Regina Henschel 2009-10-27 22:24:07 UTC
Printing a brochure in Writer with manual duplex is OK for me, imposing and
order of sheets of paper are correct. I have used a HP Color LaserJet 2605dn
with printing settings: front/normal order, back/reverse order.

Manual duplex of N-up is still not possible, that means there is no way to get
the same output as with a duplex printer, because front/back does not apply to
sheet of papers but to document pages. But I will not blame OOo for this kind of
solution, Acrobat-Reader prints the same way.

Printing a 1x2 N-Up is better now, because when printing with all pages/normal
and then all pages/reverse you get document page 2 on the back of document page
1, document page 4 on the back of document page 3, and so on. That is not a
manual duplex, but an order, which is useful when cutting the paper. 
Comment 6 christoph 2009-10-27 22:46:46 UTC
Thanks Regina :-)

I've tested the behavior (except brochure printing) and it works good.

Verified in: OOo_3.2.0_091026_unxlngi6_install (DEV310m21)