Issue 104693 - [CWS printerpullpages] brochure printing is broken
Summary: [CWS printerpullpages] brochure printing is broken
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: DEV300m55
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: OOo 3.3
Assignee: philipp.lohmann
QA Contact: issues@framework
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-01 18:25 UTC by Regina Henschel
Modified: 2010-02-03 10:08 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Document in DIN A5 portrait to be printed as brochure (28.02 KB, application/vnd.oasis.opendocument.text)
2009-09-01 18:26 UTC, Regina Henschel
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Regina Henschel 2009-09-01 18:25:10 UTC
I use a HP Color LaserJet 2605dn, which has duplex printing.

Getting a DinA5 portrait brochure in OO3.1:
Print the attached document with setting 'brochure', marked 'front pages' and
marked 'back pages'. Print all pages. Set printer to paper size DinA4,
landscape. Mark duplex printing in printer settings, do not mark brochure in
printer settings.

So I get a stack of paper with front 1/empty back 2/11, front 3/10 back 4/9,
front 5/8 back 6/7. I can fold this stack immediately to get the DinA5 portrait
brochure.

Now in CWS printerpullpages:
1. Try
Set Page Layout to 'brochure' and include 'All pages'.
Look at preview. It seems to be right, so 'Print'.

I get my document downsized to 2xDINA6 portrait printed on a DINA4 paper sheet.
What has happend? OOo sets my Printer to paper size DIN A5 portrait. Because the
tray has got only DINA4 the printer prints the document as if it has DINA5 paper.

2. Try
Set Page Layout to 'brochure' and include 'All pages'. Now I manually set my
Printer to DINA4 landscape. Look at preview. It does not look right. The
document is not downsized but shifted. And indeed printing results in a shift
with 3cm free on top long edge and 4,5cm free on left short edge.

Result: Brochure printing is not possible.
Comment 1 Regina Henschel 2009-09-01 18:26:26 UTC
Created attachment 64484 [details]
Document in DIN A5 portrait to be printed as brochure
Comment 2 Regina Henschel 2009-09-01 18:31:03 UTC
"OOo sets my Printer to paper size DIN A5 portrait" must read "... DIN A5
landscape".
Comment 3 Olaf Felka 2009-09-02 06:38:15 UTC
@ hi: Please have a look.
Comment 4 h.ilter 2009-09-02 12:40:53 UTC
I couldn't reproduce the same problem, (I took only the pages 1 till 4) but
there are a lot of other.
So the more investigate in printerpullpages, the more mistakes coming up.
I'll provide a collection list as soon as possible.

Currently it feels like as long as you print in straight direction, you should
get what you expect. But if you play with the settings back and forth, then lets
see what you get.


Comment 5 philipp.lohmann 2009-09-02 14:11:54 UTC
pl->tl: please have a look. A5 Landscape does sound about right for A6 brochure;
if you wanted to you could take the printer's paper format into account - that
logic might get a bit convoluted however.

regina: if you use the properties button to override the paperformat, than the
result you got was what you wanted. If you override the paper format of the
printer, the document will be centered on that page - unless the application
specifically changes its printed format as a reaction (like e.g. impress does).
Comment 6 Regina Henschel 2009-09-02 14:26:27 UTC
I do not understand. If I set the printer to A4 landscape, printing is not
centered but shifted.

What settings are needed in CWS printerpullpages to get the same brochure as in
OOo3.1? Please notice, the finished brochure in OOo3.1 is not a DINA6 brochure,
but a DINA5 portrait brochure. The document is not scaled in OOo3.1.
Comment 7 philipp.lohmann 2009-09-02 14:38:54 UTC
If the finished product is an A5 brochure, I'd expect you use A5 paper, not A4.
However tl is the expert on that.
Comment 8 thomas.lange 2009-09-04 12:56:19 UTC
.
Comment 9 thomas.lange 2009-09-04 12:56:49 UTC
Ooops, wrong issue. :-/
Comment 10 thomas.lange 2009-09-04 12:57:23 UTC
.
Comment 11 thomas.lange 2009-09-04 14:43:51 UTC
tl->pl, regina: The old implementation can take any page format even A2 or
letter and render a brochure that is printed on the page format of the printer.
The reason for this is that the code takes the paper size from the printer and
scales each(!) page individually to fit on that page next to the second page to
be printed.

Thus it does not really matter in what format any individual page of the
documented to be printed is. Every page could use a different page format or
switch between landscape and portrait, and still the whole page will be rendered
on the the printers paper. The only effect will be that the pages is scaled to
fit the paper.

The only special case for a A5 formatted document printed as brochure on A4
sized paper should be that the scaling factor for all pages should be 1 (or at
least very close to it).
Comment 12 thomas.lange 2009-09-07 15:56:16 UTC
tl->pl: I committed my changes, please take over for fixing the remainder of the
task.
Comment 13 philipp.lohmann 2009-09-08 16:26:37 UTC
fixed: match nearest paper (in the A5 brochure case now automatically A4
landscape gets taken)
Comment 14 philipp.lohmann 2009-09-10 13:53:16 UTC
target
Comment 15 philipp.lohmann 2009-10-26 13:26:58 UTC
please verify in CWS printerpullpages
Comment 16 Regina Henschel 2009-10-27 14:19:19 UTC
If you restrict this issue to writer, then it is fixed. But issue 105434 still
remains. In Draw both brochure and N-Up are scaled down with factor sqrt(0.5).
So brochure printing does not work in Draw.
Comment 17 philipp.lohmann 2009-10-27 14:40:53 UTC
Yes, issue 105434 remains open (and should be fixed on our way to 3.3). So this
one is verfied then ?
Comment 18 Regina Henschel 2009-10-27 14:55:30 UTC
Yes, brochure printing in _Writer_ is OK.
Comment 19 philipp.lohmann 2010-02-03 10:08:02 UTC
integrated in DEV300m70; however there is issue 108740 saying we should
reinstate scaling to the paper size of the printer. closing this issue.