Issue 104739 - Apply style error when copying characters from Impress and pasting to Writer
Summary: Apply style error when copying characters from Impress and pasting to Writer
Alias: None
Product: General
Classification: Code
Component: www (show other issues)
Version: OOo 3.1 RC2
Hardware: PC All
: P3 Trivial (vote)
Target Milestone: AOO Later
Assignee: AOO issues mailing list
QA Contact:
Keywords: oooqa
Depends on:
Blocks: 84405
  Show dependency tree
Reported: 2009-09-03 03:47 UTC by amy2008
Modified: 2017-05-20 11:35 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

Screenshot (50.46 KB, image/png)
2009-09-03 03:54 UTC, amy2008
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description amy2008 2009-09-03 03:47:57 UTC
Apply style error when copying characters (not only chinese simplified
characters but also other languese like English) from Impress and pasting to Writer
See attachment

Li Meiying
Comment 1 amy2008 2009-09-03 03:54:13 UTC
Created attachment 64509 [details]
Comment 2 thackert 2009-12-20 17:58:34 UTC
Hello amy2008,
I do not understand, what you mean with

Apply style error when copying characters (not only chinese simplified
characters but also other languese like English) from Impress and pasting to Writer

... :( Would you be so kind to elaborate it a bit? Did you first entered text in
a text box in Impress and then pasted in in Writer? If so: Have you copied the
text box or the text inside? Which OS (and which architecture) did you use?
Which version of OOo? Have you tried it with a newer version of OOo then 3.1
RC2? Does it occur there as well?
Have fun
Comment 3 redflagzhulihua 2009-12-21 03:26:43 UTC
Hi thakert,
Amy2008 is in her vacation now. But I'd like to add some comments for this one.

Input some text in the text box in impress, and copy the texts.
Switch to writer document, and paste the texts.
Move cursor into those texts, or select the texts, then you'll find some strange
style name in the style listbox, as the picture shows. It looks like some German
words with some question marks and a acronym in front.

I'll check it in a latest version, and tell you the result later. I'm downloading.

Best regards,
Comment 4 redflagzhulihua 2009-12-21 05:30:01 UTC
Hi thackert,

I have just confirmed that OOo3.2RC1 has the same behaviour.
Comment 5 Mathias_Bauer 2010-01-04 14:44:57 UTC
Oliver, please have a look and assign a suitable target
Comment 6 jbf.faure 2010-01-05 08:00:29 UTC
I confirm the defect for OOo 3.2RC1 FR under Ubuntu 8.04. 
Steps to reproduce :
- open a new presentation
- insert a text area and insert some text in it  (eg "sample of text") ; the
default font is Arial in my case, and default size is 18.
- change the color of some part of the text (eg "ample of t")
- select the whole text and copy it by ctrl+C
- open a new text document in Writer, default font is DejaVu serif 12
- paste the text by ctrl+V
- move the cursor before the letter p in "sample" and look at font name, in my
case I see "Lohit Hindi"; I have Arial only for "sam" but not for "ext" at the
end of the text.
Comment 7 jbf.faure 2010-01-05 21:48:15 UTC
Same problem when copying from writer to calc :
- create a new text document and type some text, eg: example of text, with
default font (Times New Roman 12)
- change the part "mple of t" to bold
- copy by ctrl+C the whole text "example of text"
- open a new spreadsheet
- select cell A1 (do not double-click on the cell) and paste by ctrl+V or click
copy button
==> part "exa" is in Arial (default in Calc for me) and the rest "mple of text"
is in Times New Roman

OOo 3.2 RC1 (FR) under Ubuntu 8.04  
Comment 8 Oliver Specht 2010-01-07 07:08:17 UTC
->jbfaure: You're writing about the applied font but the initial problem of this
issue is the strange style name ( "..LT..Untertitel" ) shown in the attached

Target set to 3.x
Comment 9 jbf.faure 2010-01-08 05:09:33 UTC
->os: You're right but, I do no know why, I supposed both behaviours have the
same root cause. I can file another issue if you think it is better.
Regards. JBF
Comment 10 Oliver Specht 2010-01-08 07:21:39 UTC
Impress exports the selection to the clipboard as RTF which uses such style names.
Reassigned to CL
Comment 11 thackert 2010-05-08 17:22:26 UTC
Hello amy2008, redflagzhulihua, *,
sorry for the delay, but was too busy since last December, sorry ... :(
Now I can confirm your observation with the Germanophone version of OOo under
Debian SID AMD64 ... :( The language switched - in my case - from "Arial Narrow"
to "Text Page Master~LT~Untertitel". Only the fontsize stays the same ... As os
has explained it in the last comment, why this happens, I hope he will be able
to fix it :)
Comment 12 jordis 2011-01-29 13:57:26 UTC
The initial issue about style error still persists in 3.3 RC10 (which is
actually final 3.3).
Copy text in Impress and paste it in Writer. The style name of the pasted text
will show the original style name plus some German text (eg:
Default~LT~Untertitel), as in amy2008's screenshot.
I tried with 3.3 RC10 (Catalan) in WinXP 32-bit, Win7 32-bit, Ubuntu 10.4
32-bit, MacOs PPC. Same problem in all platforms.
Comment 13 Marcus 2017-05-20 11:35:07 UTC
Reset assigne to the default "".