Issue 104782 - Crash upon Export to PDF
Summary: Crash upon Export to PDF
Status: CLOSED DUPLICATE of issue 102378
Alias: None
Product: gsl
Classification: Code
Component: code (show other issues)
Version: OOO310m11
Hardware: Mac Mac OS X, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: h.ilter
QA Contact: issues@gsl
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2009-09-04 10:24 UTC by lzib2002
Modified: 2009-09-07 23:43 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
ODT file causing a crash (15.14 KB, application/vnd.oasis.opendocument.text)
2009-09-04 10:25 UTC, lzib2002
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description lzib2002 2009-09-04 10:24:25 UTC
I observe repeated (but unfortunately not systematic) crashes of Open Office
when exporting a Write document to PDF. The documents that cause the crashes are
mostly those produced by merging data from an ODB database to a Write (ODT) file.
I have repeatedly sent automated failure reports, but never received any e-mail
(or other) confirmation.
After having clicked the "OK" button informing me that the document will be
saved for later restoration, Open Office re-starts automatically, but stops in a
form of limbo mode, where no window opens. I need to force the application to
quit, and then re-start the application all over again.
Comment 1 lzib2002 2009-09-04 10:25:46 UTC
Created attachment 64542 [details]
ODT file causing a crash
Comment 2 lzib2002 2009-09-04 10:42:10 UTC
When exporting the attached file to PDF/A1 the export does not cause Open Office
to crash, but to freeze (which then requires to force the application to quit).
The crash happens when the export is to "marked PDF".
Comment 3 philipp.lohmann 2009-09-05 11:18:37 UTC
did crash neither my OOO310m11nor DEV300m57, neither PDFA export nor tagged PDF.
Do you happen to have this problem on a Mac/PPC ? If so this is most probably a
duplicate to issue 102378.

hi: can't reproduce this, can you ?
Comment 4 lzib2002 2009-09-05 13:13:14 UTC
Indeed, my computer is a PPC Mac, and I use version 3.1.0 (310m11) of OpenOffice.

Looking at issue issue 102378, should I understand that it was solved on version
3.1.1 ?
Comment 5 hdu@apache.org 2009-09-07 06:55:16 UTC
@lzib2002: yes, OOo311 has the fix for issue 102378, please test again with this new version
Comment 6 lzib2002 2009-09-07 07:09:25 UTC
@ hdu Unofortunately, as I have mentioned before, I use a Mac/PPC, for which the
3.1.1 version does not appear yet to be available for download. I would be happy
to test as you request, but this will only be possible when the version is
ready! :=)
Comment 7 hdu@apache.org 2009-09-07 07:43:28 UTC
@lzib2002: yes indeed. AFAIK OOo311 will not be released officially for OSX-PPC but the packages Nakato 
Maho provides are quite good. The build is made from the same sources the builds for the official release 
are made:
http://ooopackages.good-day.net/pub/OpenOffice.org/MacOSX/3.1.1rc2_20090827/
Comment 8 lzib2002 2009-09-07 09:18:40 UTC
I have tested using the build you mentioned. The file for which the PDF export
caused a crash seems to work fine with this provisional version. However, when
quitting the application afterwards, OpenOffice crashes.
Comment 9 hdu@apache.org 2009-09-07 10:59:20 UTC
The PDF crash is a duplicate then. The crash at exit most probably is another issue.

*** This issue has been marked as a duplicate of 102378 ***
Comment 10 lohmaier 2009-09-07 23:43:50 UTC
closing duplicate.

As for PPC releases: Maho's builds are the "official" source for Mac/PPC
packages (and also for Intel before Sun joined the Mac-port and started
providing builds for Intel). However they will only be declared as releases and
put onto the main mirror network when someone did QA them. 
Unfortunately there are very, very few volunteers for this for PPC. Until then,
you'll have to use the good-day mirror and get the RC (when a release is
approved, the tested RC will just be renamed and distributed)

It's kind of sad that there still is confusion about the release procedure,
although the process is used for years now :-/

Anyway: closing. Please file seperate issues for any remaining problems.