Issue 104808 - VBA macro does not work
Summary: VBA macro does not work
Alias: None
Product: General
Classification: Code
Component: scripting (show other issues)
Version: 3.4.0
Hardware: All All
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2009-09-04 15:54 UTC by fw89429
Modified: 2014-03-06 14:35 UTC (History)
3 users (show)

See Also:
Latest Confirmation in: 4.1.0-dev
Developer Difficulty: ---

sample XLS file (322.00 KB, application/
2009-10-12 08:20 UTC, fw89429
no flags Details
Excel 2010 vs. Calc 4.1 (202.93 KB, image/png)
2014-03-06 14:34 UTC, Edwin Sharp
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description fw89429 2009-09-04 15:54:11 UTC
I was sent an Excel sheet containing VBA macros. On my MacBook Pro (intel), OO
3.0 opened the sheet but refuses to run the macros, even with lowest security
settings. After OO 3.1 was released, I thought it might work / not true. The
same with OO 3.1.1. I remember having tried it some time ago on my PowerMac
(PPC) running NeoOffice: no probs.
As this is getting a real issue now, I also tried it with StarOffice 8 on
Solaris (SPARC): no success. I asked a colleague to try it on Windows (OO 2.4):
this works.
Comment 1 fw89429 2009-09-09 08:30:35 UTC
Of course, the macro security settings were identical in all cases.

And for those who are wondering what "it doesn't work" means: instead of a
result, just the "### MACRO ###" things appears in the affected cells.
Comment 2 Rainer Bielefeld 2009-10-10 17:19:20 UTC
Correct Version due to report.

Can you please attach a sample document?
Comment 3 fw89429 2009-10-12 08:20:22 UTC
Created attachment 65306 [details]
sample XLS file
Comment 4 Rainer Bielefeld 2009-10-22 06:16:29 UTC
I see the "MACRO?" string in "sample.xls", with other Load/Save VBA settings I
get empty cells. May be particular macro code is not supported ba OOo? May be
NeoOffice has improved VBA support?

DUP of  Issue 79854?
Comment 5 fw89429 2009-11-05 15:49:52 UTC
Another idea: I'm not 100% sure but maybe it works on those machines where M$
Office is installed. On my PowerMac, there is a trial version installed. As I
re-installed MacOS on my MacBook Pro, there is no M$ Office. The same applies to
Solaris :) ... and my colleague's Windows machine definitely has M$ Office
besides OO.

Is this a valid approach? Is there something like a libvba.dylib which we need?
Comment 6 fw89429 2010-01-22 11:20:36 UTC
Any updates on this?
Comment 7 fw89429 2011-02-03 15:34:14 UTC
Still broken in OOo 3.3
Comment 8 Edwin Sharp 2014-01-11 18:31:34 UTC
Internal import error.

AOO410m1(Build:9750)  -  Rev. 1555399
2014-01-06_04:13:46 - Rev. 1555657
Comment 9 Rainer Bielefeld 2014-01-11 19:26:15 UTC
Currently I do not understand CONFIRMED and "Regression". 
* Do we KNOW any OO version and any Machine where the macro in the sample document works? 
* Has been checked whether document is in accordance with "VBA interoperability in OpenOffice"?
* With what VBA Settings have the tests been done?
Comment 10 Edwin Sharp 2014-01-11 19:41:42 UTC
Did you open the file in comment 4?
I can't!
Comment 11 Rainer Bielefeld 2014-01-12 07:12:57 UTC
Unfortunately I only have MS OFFICE Starter 2010, what does not support Macro execution. 

Remove "regression" because currently no OOo Version known where VBA macros of sample document 

@Edwin Sharp
This report is concerning not working VBA Macros. If you have a problem to open the document ("Read-Error") please submit a separate bug, but do not hijack this one.
Comment 12 Edwin Sharp 2014-03-06 14:34:11 UTC
Created attachment 82803 [details]
Excel 2010 vs. Calc 4.1
Comment 13 Edwin Sharp 2014-03-06 14:35:18 UTC
Confirmed with
AOO410m14(Build:9760)  -  Rev. 1573601
2014-03-03 17:47:48 (Mo, 03 Mrz 2014)
Win 7