Issue 104862 - WW8: document containing several graphics loops Writer right after import
Summary: WW8: document containing several graphics loops Writer right after import
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: open-import (show other issues)
Version: OOO310m19
Hardware: All All
: P2 Trivial with 1 vote (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords: oooqa, regression
Depends on:
Blocks:
 
Reported: 2009-09-07 14:33 UTC by ctcreel
Modified: 2013-08-07 14:44 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Here is a zip of the file that is causing Writer 3.1.1 to crash (9.85 MB, application/msword)
2009-09-07 15:38 UTC, ctcreel
no flags Details
Here is a video clip of me reproducing the bug (2.99 MB, application/octet-stream)
2009-09-07 15:59 UTC, ctcreel
no flags Details
Same document but in Word 2007 format. Notice how the first page is messed up. (8.17 MB, text/plain)
2009-09-07 16:39 UTC, ctcreel
no flags Details
PDF print of the document in question (2.76 MB, text/plain)
2009-09-07 16:40 UTC, ctcreel
no flags Details
Shorter version of document (159.00 KB, application/msword)
2009-09-10 15:33 UTC, michael.ruess
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description ctcreel 2009-09-07 14:33:57 UTC
We use Open Office internally and as a part of the Alfresco Enterprise edition 
where Open Office runs headless.  We recently upgraded from version 2.3 to version 
3.1.1 and noticed that suddenly a number of documents began freezing Alfresco. 
Upon closer inspection we discovered that the problem was that the Open Office 
process hangs.  The CPU shoots up to 100% and it just sits there for as long as we 
let it. We attempted to load those same documents in to a stand alone version of 
Open Office Writer and noticed the exact same behavior.  This same document opens 
fine in Open Office Writer version 2.3.
Comment 1 Rainer Bielefeld 2009-09-07 15:00:35 UTC
@ctcreel:
Pls. specify OSs and Platfrms aou tested. 
Pls. describe more detailed how you use OOo and in which moment after starting
OOo the freeze happens. 
Can you please attach such a document (If it's confidential, pls. send to my by PM)?

Please read our guidelines on
<http://qa.openoffice.org/issue_handling/pre_submission.html> and  
<http://www.openoffice.org/bugs/bug_writing_guidelines.html> so that you can
contribute optimum information, then contribute a clear step by step instruction
containing all observations (error messages ...),
_every_key_press_and_every_mouse_click_ how to reproduce the problem, and
explain why you believe that your results are unexpected.
That means (for example): 
 do not write something like „I am not able to ...“, but
 „6. left mouse click on …
     expected: …, color of … changes, … 
     actual: no …., color remains white, no …
Comment 2 ctcreel 2009-09-07 15:38:04 UTC
Created attachment 64588 [details]
Here is a zip of the file that is causing Writer 3.1.1 to crash
Comment 3 ctcreel 2009-09-07 15:59:13 UTC
Created attachment 64590 [details]
Here is a video clip of me reproducing the bug
Comment 4 ctcreel 2009-09-07 16:00:01 UTC
Be sure to maximize the window on that video clip.
Comment 5 Rainer Bielefeld 2009-09-07 16:14:11 UTC
I checked with document from "Users Guide v1.zip" "Ooo 3.1.1 WIN XP
DE-multilingual version German UI activated [OOO310m19 (Build 9420)]" and can
confirm the reported effect, OOo hangs when trying to open document. No progress
within 10 minutes with 100% CPU load. Works fine with 2.0.2!

@ctcreel:
Can you please contribute information with what program those documents have
been created?
Comment 6 Rainer Bielefeld 2009-09-07 16:24:12 UTC
And it does not look better with "Ooo Dev 3.2.0 multilingual version English UI
WIN XP: [DEV300m57 (Build 9422)]"
Comment 7 ctcreel 2009-09-07 16:37:28 UTC
The document was created using Microsoft Office Word 2003.  Note that if I save 
this document in Microsoft Word 2007 that Open Office Writer will open the file 
but it the graphics in the beginning are messed up.  I have attached the document 
saved in 2007 format so you can see for yourself.  I have also attached a Print so 
you can see what it is supposed to look like.
Comment 8 ctcreel 2009-09-07 16:37:40 UTC
The document was created using Microsoft Office Word 2003.  Note that if I save 
this document in Microsoft Word 2007 that Open Office Writer will open the file 
but it the graphics in the beginning are messed up.  I have attached the document 
saved in 2007 format so you can see for yourself.  I have also attached a Print so 
you can see what it is supposed to look like.
Comment 9 ctcreel 2009-09-07 16:39:07 UTC
Created attachment 64591 [details]
Same document but in Word 2007 format.  Notice how the first page is messed up.
Comment 10 ctcreel 2009-09-07 16:40:26 UTC
Created attachment 64592 [details]
PDF print of the document in question
Comment 11 ctcreel 2009-09-09 23:39:32 UTC
Please note that an issue has been filed with the Alfresco project as well -

https://issues.alfresco.com/jira/browse/ETHREEOH-2827
Comment 12 michael.ruess 2009-09-10 15:33:54 UTC
Created attachment 64674 [details]
Shorter version of document
Comment 13 michael.ruess 2009-09-10 15:37:10 UTC
The only odd thing which I see is that there are many graphics in the document.
Comment 14 ctcreel 2009-12-09 22:33:00 UTC
Any movement on this issue?
Comment 15 Oliver-Rainer Wittmann 2009-12-10 08:00:51 UTC
OD->ctcreel:
I had no time to evaluate this issue, yet.
If nothing prevents me I will have a look in the next days.
Comment 16 Oliver-Rainer Wittmann 2009-12-10 09:38:28 UTC
First investigation reveals that a paragraph with an as-character anchor graphic
is endlessly moving forward to the next page. In the stripped document it is the
paragraph on page 5 at the end of the page which is in OOo Writer endlessly
moving forward.

Deeper investigation for the root cause is needed.
Comment 17 Oliver-Rainer Wittmann 2011-03-10 09:11:42 UTC
The layout loop with the Microsoft Word file in WW8 file format is no longer reproducable in DEV300m102 nor in OOo 3.3

od->mru: Please confirm an close this issue.
Comment 18 michael.ruess 2011-03-10 10:44:13 UTC
Agree, this works at least since OOo 3.3.
Comment 19 michael.ruess 2011-03-10 10:45:45 UTC
Closed, it looks, that this problem benefited from fix of issue 111750.