Issue 105054 - Close last doc quits OOo instead of keep the Start center (not visible on Mac)
Summary: Close last doc quits OOo instead of keep the Start center (not visible on Mac)
Status: CLOSED DUPLICATE of issue 105753
Alias: None
Product: performance
Classification: Code
Component: www (show other issues)
Version: current
Hardware: Mac Mac OS X, all
: P3 Trivial (vote)
Target Milestone: not determined
Assignee: philipp.lohmann
QA Contact: issues@performance
URL:
Keywords:
: 105250 (view as issue list)
Depends on:
Blocks:
 
Reported: 2009-09-14 12:51 UTC by eric.bachard
Modified: 2009-10-14 09:51 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
a workaround, waiting for a better solution (I'll search from my side too) (935 bytes, patch)
2009-09-14 12:54 UTC, eric.bachard
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description eric.bachard 2009-09-14 12:51:32 UTC
Mac OS X Tiger (Intel machine) 

Open a new empty document (whatever)

close it -> OOo quits

Expected : the application stays open, and CMD+N opens the start center

The issue is in the app.cxx, around line 1733, when bQuickStart is tested -> Mac OS X shouldn't be 
concerned, or maybe there is a problem with Tiger .. 

Will attach a patch, as workaround, waiting a more complete solution is found.
Comment 1 eric.bachard 2009-09-14 12:54:48 UTC
Created attachment 64751 [details]
a workaround, waiting for a better solution (I'll search from my side too)
Comment 2 philipp.lohmann 2009-09-14 13:37:39 UTC
sorry, but that issue doesn't happen in the first place. OOo doesn't quit on Mac
if you close the last document
Comment 3 eric.bachard 2009-09-14 13:46:55 UTC
@pl : FYI, I'm using Tiger.  Do you use it, or a more recent version ?
Comment 4 philipp.lohmann 2009-09-14 14:08:18 UTC
Works the same on both tiger and leopard.
Comment 5 eric.bachard 2009-09-14 14:25:48 UTC
@pl : ok, will restart a clean build, to be sure
Comment 6 ocke.janssen 2009-09-21 08:29:57 UTC
@pl: Seems to be yours.
Comment 7 hdu@apache.org 2009-09-23 11:36:44 UTC
*** Issue 105250 has been marked as a duplicate of this issue. ***
Comment 8 eric.bachard 2009-10-13 23:23:14 UTC
@pl

Hi Philipp. I have seen your changes in
http://svn.services.openoffice.org/ooo/cws/ooo32gsl02/desktop/source/app/app.cxx
, and I wonder what was wrong with my patch ?

btw : looks like you added the wrong issue number in the comment (if I'm not wrong).
Comment 9 philipp.lohmann 2009-10-14 09:50:40 UTC
nothing was wrong, however after 2 weeks vacation I didn't remember it and
debugged the problem myself.

*** This issue has been marked as a duplicate of 105753 ***
Comment 10 philipp.lohmann 2009-10-14 09:51:00 UTC
closing