Issue 105084 - OpenSymbol font: Math related changes
Summary: OpenSymbol font: Math related changes
Status: CLOSED FIXED
Alias: None
Product: Installation
Classification: Application
Component: ui (show other issues)
Version: DEV300m55
Hardware: All All
: P3 Trivial with 2 votes (vote)
Target Milestone: OOo 3.3
Assignee: michael.ruess
QA Contact: issues@installation
URL:
Keywords:
: 80843 (view as issue list)
Depends on:
Blocks: 50314 53223 69108 75472 79037 92203 80843 93925 105085 106815 110654 113918
  Show dependency tree
 
Reported: 2009-09-15 11:11 UTC by thomas.lange
Modified: 2010-08-18 09:18 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Document with table of the required changes (208.63 KB, application/octet-stream)
2009-09-15 11:13 UTC, thomas.lange
no flags Details
new Version (1.99) of OpenSymbol Font (195.99 KB, application/octet-stream)
2009-10-30 17:44 UTC, nospam
no flags Details
new Version (2.0) of OpenSymbol Font (196.17 KB, application/octet-stream)
2009-11-02 11:37 UTC, nospam
no flags Details
new Version (V2.1) of OpenSymbol Font (188.19 KB, application/octet-stream)
2009-11-09 15:25 UTC, nospam
no flags Details
Version 2.2 of the OpenSymbol Font (202.09 KB, application/octet-stream)
2009-12-02 09:57 UTC, nospam
no flags Details
New Version 2.3.8 of OpenSymbol Font (194.01 KB, application/octet-stream)
2009-12-17 09:48 UTC, nospam
no flags Details
New Version 2.3.9 of OpenSymbol Font (194.01 KB, application/octet-stream)
2009-12-17 14:03 UTC, nospam
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description thomas.lange 2009-09-15 11:11:54 UTC
The OpenSymbol font needs to adapt quite a few changes in order for other Math
issue to be fixable.

For Example:
- symbols from the private-use are need to be copied to the correct 
code points in order to fix export problems.
- the shape of all Greek characters should be changes since they are slanted by
default, but the font is not.

For a complete list see the attached document.
Comment 1 thomas.lange 2009-09-15 11:13:43 UTC
Created attachment 64766 [details]
Document with table of the required changes
Comment 2 thomas.lange 2009-09-15 11:14:47 UTC
.
Comment 3 thomas.lange 2009-09-15 11:22:07 UTC
TL: When the font is changed Math needs to make the respective
code/configuration changes to make use of the new code-points. See issue 105085.
Comment 4 thomas.lange 2009-09-15 11:58:32 UTC
.
Comment 5 nospam 2009-09-25 10:51:34 UTC
started
Comment 6 nospam 2009-10-30 17:43:11 UTC
I have adapted almost all topics of TL's Req. Document. New Version of the font is attached. Please not 
that some things will still be "strange" (e.g. some capital greek letters) - until TL changes the Math code.
Comment 7 nospam 2009-10-30 17:44:43 UTC
Created attachment 65806 [details]
new Version (1.99) of OpenSymbol Font
Comment 8 nospam 2009-11-02 11:37:35 UTC
Created attachment 65852 [details]
new Version (2.0) of OpenSymbol Font
Comment 9 nospam 2009-11-02 11:38:04 UTC
@all: please test the new version of the font
Comment 10 nospam 2009-11-09 15:25:13 UTC
Created attachment 66020 [details]
new Version (V2.1) of OpenSymbol Font
Comment 11 nospam 2009-11-09 15:27:18 UTC
Unfortunately I took a wrong list of needed changes for the first Version of the font. Now I took the list 
attached to this issue and made some corrections. I attached V2.1 of the font to the issue.
Comment 12 thomas.lange 2009-11-12 15:17:15 UTC
Files changed:

M extras/source/truetype/symbol/OpenSymbol.sfd
M extras/source/truetype/symbol/opens___.ttf
Comment 13 thomas.lange 2009-11-17 14:09:48 UTC
Adding hdu to CC.
Comment 14 nospam 2009-12-02 09:57:14 UTC
Created attachment 66449 [details]
Version 2.2 of the OpenSymbol Font
Comment 15 nospam 2009-12-02 09:58:57 UTC
New version of font attached: correction: 03d5 and 03c6 exchanged
Comment 16 thomas.lange 2009-12-04 09:05:15 UTC
OpenSymbol font v 2.2 added to CWS.
Comment 17 thomas.lange 2009-12-04 15:44:43 UTC
.
Comment 18 nospam 2009-12-17 09:48:29 UTC
Created attachment 66679 [details]
New Version 2.3.8 of OpenSymbol Font
Comment 19 nospam 2009-12-17 14:03:27 UTC
Created attachment 66693 [details]
New Version 2.3.9 of OpenSymbol Font
Comment 20 nospam 2009-12-17 14:03:52 UTC
2.3.9: size of en-dash set to 1024
Comment 21 michael.ruess 2010-01-08 14:02:10 UTC
Verified in CWS tl76.
Comment 22 michael.ruess 2010-01-28 11:50:24 UTC
Checked in DEV300m70.
Comment 23 hdu@apache.org 2010-06-04 14:04:02 UTC
*** Issue 80843 has been marked as a duplicate of this issue. ***