Issue 105106 - Vertical Text has a wrong position when change its direction
Summary: Vertical Text has a wrong position when change its direction
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: Impress
Classification: Application
Component: code (show other issues)
Version: DEV300m58
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: clippka
QA Contact: issues@graphics
URL:
Keywords:
Depends on:
Blocks: 84405
  Show dependency tree
 
Reported: 2009-09-16 06:53 UTC by amy2008
Modified: 2013-08-07 15:20 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
original vertical text (44.89 KB, image/png)
2009-09-18 03:39 UTC, redflagzhulihua
no flags Details
we changed the direction of text, but anchor didn't change. so it looks like this, the left side of the frame is blank. This is not intuitive. (45.08 KB, image/png)
2009-09-18 03:41 UTC, redflagzhulihua
no flags Details
While Draw changed the anchor by 90 degree CCW. This is intuitive to users. (38.32 KB, image/png)
2009-09-18 03:43 UTC, redflagzhulihua
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description amy2008 2009-09-16 06:53:40 UTC
How to reproduce it
1 Create a new Impress file
2 Apply "Vertical Title, Vertical Text" layouts for slide 1
3 Input more than one outline for slide 1, like "outline1, outline2, outline3"
4 Select these outlines, click "Text direction from left to right", then Pay
  attention to the text alignment

Result
After step 4, text seems to be on the right of the text box; but text alignment 
is "Align left" on the toolbar.

Expectation
Alignment for text works well.

Regards
Li Meiying
Comment 1 wolframgarten 2009-09-16 08:07:04 UTC
Reproducible. Reassigned.
Comment 2 clippka 2009-09-16 11:00:35 UTC
This actually works as designed. The paragraph text alignment aligns paragraph
in relation to each other. If all paragraphs have the same length it does not
matter if the alignment is left or right.

What you are looking for is the text anchor where you can align the text area in
relation to the shapes size.

I know this is confusing but it is caused by the fact that a text shape is just
a shape with no filling so it has all features that a circle or rectangle would
have and that includes the feature of having a text area that can be anchored
inside the shape.

This is only visible in presentation shapes like title or outline because the
default text shape is never bigger than the text contained. In that case the
text anchor does not matter.
Comment 3 clippka 2009-09-16 11:01:00 UTC
closing
Comment 4 redflagzhulihua 2009-09-17 10:28:34 UTC
Hi cl,

Are you sure you commented on the right issue? or maybe you missunderstand the
description, because there are some issues in it.
First, this is not a "presentation issue", I think the component should be
"framework" or "drawing". Because it works well in drawing, So I choose
component "framework".
And, the description, I modify it as follow:

1. Insert a vertical text in OOo Document(any application other than drawing)
2. Input several lines of texts in it
3. click "Text direction from left to right" in the toolbar

Result: The editing area is restricted to to right top conner of the text frame.

In fact, the alignment buttons works well, just the position of the text is not 
correct.

@wg: What do you think of it?
Comment 5 clippka 2009-09-17 10:48:39 UTC
Hi zhulihua,

please do not reopen issues to report different bugs. The bug described by amy
was about the presentation layout vertical text.

Your new descriptions also does not show a bug, the text anchor for a vertical
text box is top-right so OOo is correct. If you want the text to be at top-left
you have to change the text anchor.

please do not use framework as a project for issues in presentation (which is
for presentation documents) or drawing (which is for issues only available in
drawing documents but also for issues with shapes in other applications)
Comment 6 clippka 2009-09-17 10:50:33 UTC
closing.

Please all note that text anchor, paragraph alignment and text direction are
three independent features. Just because you change one do not expect the others
to behave different than before.
Comment 7 redflagzhulihua 2009-09-17 14:11:50 UTC
Hi cl,

This issue I described is the one amy2008 reported. I discussed this with her.
The original describe have some mistakes, so I corrected it.

The issue have nothing to do with outline or layout or alignment. if you use
"vertical text", the issue will show up.

I agree with you that the text anchor is top-righted, but why can't we change it
automatically to top-left when we click "Text direction from left to right"?
Just like Draw does. You can see this works well in Draw. And it's more
intuitive to the users. And can make the application correspond with each other.

Since this issue reproduces in all the module beside Draw, so I choose
framework. It's not a issue only in presentation.

Please reconsider, if you can confirm, maybe I need file another issue about
this, because there are mistakes in the original description.
Comment 8 clippka 2009-09-17 15:54:34 UTC
draw and impress have the same behavior. The difference is that vertical text
boxes have the default text anchor top right in impress and right with full
width in draw.

If text direction is switched from vertical to horizontal then the text anchor
switches left or right to top or bottom. For some reasons I don't know it does
not switch the corner settings like top right.

I'm no export on text and sure not on complex text so I can't tell why it was
decided that the defaults for vertical text boxes are different in draw and
impress. Also I don't know why the switching behavior is the way it is. I will
not change anything here except someone can explain to me why it should be changed..
Comment 9 redflagzhulihua 2009-09-18 03:37:35 UTC
Hi cl,

Thanks for the information.

Yes, you are right. The real reason is the anchor. In Draw, the anchor changed
to a right place after we change the direction. But in other applications, the
anchors don't change. They remain to stay at the original place.
Comment 10 redflagzhulihua 2009-09-18 03:39:02 UTC
Created attachment 64826 [details]
original vertical text
Comment 11 redflagzhulihua 2009-09-18 03:41:42 UTC
Created attachment 64827 [details]
we changed the direction of text, but anchor didn't change. so it looks like this, the left side of the frame is blank. This is not intuitive.
Comment 12 redflagzhulihua 2009-09-18 03:43:34 UTC
Created attachment 64828 [details]
While Draw changed the anchor by 90 degree CCW. This is intuitive to users.
Comment 13 redflagzhulihua 2009-09-18 03:46:03 UTC
All the applications should work as Draw does. 
Comment 14 redflagzhulihua 2009-09-18 04:51:11 UTC
And I just found, changing text direction in a Horizon Text, the anchor changed
90 degree CW. I think this is the right behavior.