Issue 105235 - setting default values in subform don't allow subform itself to work
Summary: setting default values in subform don't allow subform itself to work
Status: CLOSED FIXED
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOO310m1
Hardware: All Windows XP
: P3 Trivial (vote)
Target Milestone: OOo 3.2
Assignee: marc.neumann
QA Contact: issues@dba
URL:
Keywords:
: 105166 106543 (view as issue list)
Depends on:
Blocks: 99999
  Show dependency tree
 
Reported: 2009-09-21 08:50 UTC by fornarif
Modified: 2017-05-20 10:29 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
default values don't allow subform grid to work (55.37 KB, text/plain)
2009-09-21 08:52 UTC, fornarif
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description fornarif 2009-09-21 08:50:14 UTC
I built a simple form with a subform grid in a one to many relation. All worked
as expected until I tried to set a default value for one column of the grid.
Then, the behaviour of grid changed as follows: I'm still able to add new
records in subform when at least one previous record do exist in it. Instead, if
the selected record in main form still has no records in subform, no default
values are visible and any value manually inserted disappears when the column
looses focus.
I noticed only one exception to this, when the very first record in main form
has no entries in subform and I have just opened the main form. In this and only
this case, all works as expected. But as long as I move to the second record in
main form and go back, default values disappear and subform doesn't work anymore.
Comment 1 fornarif 2009-09-21 08:52:12 UTC
Created attachment 64878 [details]
default values don't allow subform grid to work
Comment 2 Frank Schönheit 2009-09-25 13:53:48 UTC
confirming, grabbing, targeting.

I suppose this is a duplicate of issue 105116 (or the other way 'round), since
both are pretty similar. However, there are also some slight differences, so I
keep both issues open for the moment.
Comment 3 Frank Schönheit 2009-09-25 14:35:22 UTC
Uhm, I meant to say issue 105166
Comment 4 Frank Schönheit 2009-09-28 12:30:54 UTC
fixed in CWS dba33a

find more information about this CWS, like when it is available in the master
builds, in EIS, the Environment Information System:
http://eis.services.openoffice.org/EIS2/cws.ShowCWS?Path=DEV300%2Fdba33a
Comment 5 Frank Schönheit 2009-09-28 12:41:45 UTC
*** Issue 105166 has been marked as a duplicate of this issue. ***
Comment 6 Frank Schönheit 2009-10-02 13:40:08 UTC
copying fix to CWS dba32h, now that the bug got the approval for 3.2
Comment 7 Frank Schönheit 2009-10-07 09:01:16 UTC
fs->clu: please verify in CWS dba32h
Comment 8 Frank Schönheit 2009-10-07 09:01:28 UTC
fs->msc: please verify in CWS dba32h
Comment 9 marc.neumann 2009-10-07 09:26:51 UTC
verified in CWS dba32h

find more information about this CWS, like when it is available in the master
builds, in EIS, the Environment Information System:
http://eis.services.openoffice.org/EIS2/cws.ShowCWS?Path=DEV300%2Fdba32h
Comment 10 Frank Schönheit 2009-11-03 11:17:35 UTC
*** Issue 106543 has been marked as a duplicate of this issue. ***
Comment 11 Frank Schönheit 2009-11-05 13:34:37 UTC
note: created a test case for this in
forms/qa/integration/forms/MasterDetailForms.java.