Issue 105238 - Monospaced fonts wrongly displayed (DejaVu, Bitstream) after reloading document
Summary: Monospaced fonts wrongly displayed (DejaVu, Bitstream) after reloading document
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: formatting (show other issues)
Version: OOo 3.1
Hardware: All Windows, all
: P3 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords: regression
Depends on:
Blocks: 99999
  Show dependency tree
 
Reported: 2009-09-21 10:52 UTC by alfayate
Modified: 2013-08-07 14:44 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Example of monoespaced font (Bitstream Vera Mono) wrong displayed (6.48 KB, image/png)
2009-09-21 10:54 UTC, alfayate
no flags Details
Examples of fonts (10.50 KB, application/vnd.oasis.opendocument.text)
2009-09-25 09:43 UTC, alfayate
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description alfayate 2009-09-21 10:52:18 UTC
In OpenOffice 2.3, you write something using a monospaced font that is installed
with the application (Bitstream Vera Mono, in this case). When you open the file
with OpenOffice 3.1, the first time the document is displayed ok, but when you
open it again, the text written with this font looks all compressed (see the
attached image) like there was a problem with the kerning. Same thing happens if
you use OpenOffice 3.1 with DejaVu Sans Mono and the try to open it with
OpenOffice 2.3

I mention Oo 3.1.0 and 2.3.0 because these are the versions in which I tracked
the problem, but I guess this would happen with any other two versions that use
a different default font (Bitstream Vera was the default font installed until Oo
3, in which is DejaVu). By the way, this only happens in Windows (I cheked it
out in Linux and it was ok) and with the monospaced versions of the fonts. No
surprise, since I think it's related to font sustitution and these fonts are
common in Linux but not in Windows.

Anyway, if you select the text and change the font, it's displayed ok again.
Same thing if you close the quick start icon and open the file again. Also if
you enable WebLayout view, the text is clearly displayed again. Anyhow I think
that's NOT the infamous "Print Layout" vs. "Web Layout" issue, since the first
time you open the document is displayed well in both views, so it's related to,
but there must be something else involved.

Some people may think this is a trivial error, but if you need to work with
different systems (Linux/Windows) and different people, you think that using a
font installed with Oo it's format-safe but sooner or later, someone finds that
Oo has "ruined" part of  the text, and althougt the solution may be simple, it's
not obvious at all, and anyway, that's not how Oo is expected to work.

Thanks for your attention. Kind regards

Carlos F.
Comment 1 alfayate 2009-09-21 10:54:56 UTC
Created attachment 64881 [details]
Example of monoespaced font (Bitstream Vera Mono) wrong displayed
Comment 2 michael.ruess 2009-09-24 14:54:44 UTC
I cannot confirm this using Bitstream Vera Sans Mono in my documents. Could you
please attach your sample to this issue? Thanks a lot!
Comment 3 alfayate 2009-09-25 09:42:17 UTC
Hello mru.

Thanks a lot for your response. I send an attachment, an odt document with
several font examples, including Bitstream Vera Mono and DejaVu Sans Mono.

The point is that you mustn't have Bitstream Vera family installed in your
system, so I guess you'll need two different systems with different Oo versions.
I'm sorry I didn't explain myself clear enough. I'll try to be more exhaustive:

I tried with several other fonts (monospaced and non-monospaced, including
Courier New) and the only ones that are problematic are DejaVu Sans Mono and
Bitstream Vera Sans Mono. But I don't think the problem it's in the fonts, the
results of the tests make me think that it's a mix of font sustitution and the
"Print Layout" vs. "Web Layout" issue.

DejaVu and Bitstream Vera are free font families common in Linux, but not in
Windows. As far as I know, Oo 2.x installed Bitstream Vera on the system, but
now Oo 3.x installs DejaVu. I noticed that when the specific font is installed
in the system, there´s no problem with it, so in this case, no matter what Oo
version you're using, the text is displayed OK in Linux. The same goes for
Bitstream on Oo 2 and DejaVu on Oo 3 in Windows. But when you use DejaVu Sans
Mono in Oo 3 and then you open the document in Oo 2, the problem arises. And
also when you use Bitstream Vera Mono in Oo 2 and you open the document in Oo 3.
So I guess that when Oo tries to substitute a font, and this font is
monoespaced, something happens and it's displayed with the wrong kerning,
overlapping the characters.

The weird thing is that this only happens in Print Layout mode. Also, when you
open the document the first time, it's displayed OK, the next time you open the
document is when it's bad displayed; that makes me think that it's some kind of
obscure program failure in the Print Layout mode...

I don't think the problem relays in a certain font, but in the way Oo treats it
and displays it:

a) The first time you open the doc, it's displayed OK. If there was a problem
within the font, it should be bad displayed always.

b) In fact, there's no font!. As I explained before, the font is not installed
in the system where the error happens. To be more precise, the problem is not
with the font, but with the sustitution of the font. That is: for example, the
system does not have the Bitstream Vera font family, the text written in
Bitstream Vera Sans is displayed OK (so, the font is supposed to has been well
replaced), but the text written in Bitstream Vera Sans Mono is "crunched".

Anyway, I think the relevance of this problem lies in this point: it undermines
one of the strongs of Oo, the possibility of working with a standard format, no
matter the system and (up to some point, at least) the version of the
application. To get this accomplished, you need some system-independent fonts,
that technically and legally could be distributed and installed with Oo;
Bitstream (and now DejaVu) are the font families chosen and so, they should be
fully reliable and functional. Of course, you can't blame Oo for an error of the
font itself but I think this is not the case here.

Thanks for your attention. Hope it helps

Carlos
Comment 4 alfayate 2009-09-25 09:43:17 UTC
Created attachment 64962 [details]
Examples of fonts
Comment 5 michael.ruess 2009-10-15 16:07:17 UTC
This happens when e.g. Bitstream fonts are NOT installed on the system. Open the
attached file and see the fonts displayed correctly. Now reload file -> the
fonts are displayed squeezed.
Comment 6 hdu@apache.org 2009-11-12 10:41:28 UTC
The fallback for "bitstreamverasansmono" was misspelled as "bitstreamveramonosans".
I added the regression keyword documents layouted for older installations with the Bitstream*Mono fonts 
look bad. Fixing the spelling is a save solution that would be good for OOo32 too.

The other question why Writer makes a difference between original load and reload is still not understood. 
For fixing this problem this does not matter though.
Comment 7 uwe.luebbers 2009-11-12 15:40:15 UTC
3.2 stopper issue, adjusted target
Comment 8 hdu@apache.org 2009-11-13 12:38:58 UTC
Fixed in CWS ooo32gsl06 and CWS vcl108
Comment 9 alfayate 2009-11-16 09:37:04 UTC
Thanks to everyone involved!

As for the question why Writer makes a difference between original load and
reload, I think it's related to Oo quick start, since if you shut it down, the
error doesn't happen. Hope it helps


Comment 10 hdu@apache.org 2009-11-18 10:18:28 UTC
@mru: please verify in CWS ooo32gsl06
Comment 11 michael.ruess 2009-11-23 10:56:10 UTC
Verified in CWS ooo32gsl06.
Comment 12 michael.ruess 2010-01-28 11:45:24 UTC
Checked fix in DEV300m70 and OOO320m11.