Issue 105267 - VoiceOver turned on: Calc crashes after entering formula
Summary: VoiceOver turned on: Calc crashes after entering formula
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: DEV300m59
Hardware: Mac Mac OS X, all
: P2 Trivial (vote)
Target Milestone: OOo 3.2
Assignee: oc
QA Contact: issues@framework
Keywords: accessibility, aqua
Depends on:
Blocks: 99999
  Show dependency tree
Reported: 2009-09-22 13:29 UTC by mdxonefour
Modified: 2010-01-08 09:14 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

mapped stack (5.89 KB, text/plain)
2009-09-23 07:30 UTC,
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description mdxonefour 2009-09-22 13:29:54 UTC
- Running MacOS X Snow Leopard and having a11y tool VoiceOver turned on.
- Opening DEV300m59 or if you prefer OOo 3.1.1 final release spreadsheet.
- Enter "1" into A1
- Enter "2" into A2
- Create SUM in A3 via sum icon in toolbar.
- Right after pressing return key to have the sum, Calc crashes.

MD: As suggested by MT I put this issue to HDU initially.
Comment 1 2009-09-22 14:39:31 UTC
Was a crash report sent? What is the reportid?
Comment 2 mdxonefour 2009-09-22 14:58:14 UTC
MD->HDU: Unfotunatly no CrashReporter shows up in this case. It seems like we
crash in a way the crash reporter can't hook on intime.
Comment 3 2009-09-22 16:20:14 UTC
Was able to reproduce the problem: the reportids were r2mtpdc, rkmtpdc, rumtpdc
For debugging I tried to use unstripped versions of the involved libraries, but it showed that the problem 
disappears then! IIRC libscdmxi.dylib and libsvxcoremxi.dylib made the difference. This could be an 
indication that the problem is really a build problem. I suggest to test if this also happens with m60++.
Comment 4 mdxonefour 2009-09-22 18:28:05 UTC
MD->HDU: For sure I can have a look at m60++ too, but I didn't get the point
here. I tried 3.1.1 final release and the DEV300m59 already.
Comment 5 2009-09-23 07:30:00 UTC
Created attachment 64909 [details]
mapped stack
Comment 6 2009-09-23 07:37:02 UTC
In the appended stack a11y and EditEngine have quite prominent roles -> @MT: any input on what is 
going in these hot topics of yours?
Comment 7 malte_timmermann 2009-09-23 08:52:45 UTC
I don't know the accessibility implementations for the EditEngine.

But when EditEngine::GetRefMapMode() crashes, it can only mean that the pointer
to the EditEngine or it's RefDevice is invalid/dead.
Comment 8 2009-09-24 11:57:13 UTC
@dr: as we saw in our debugging session the problem seems to be that the timing of VoiceOver on Snow 
Leopard is different, so that a notification gets delivered later. At that time an EditEngine/EditView 
corresponding to the accessibility event has already become invalid.
Comment 9 mdxonefour 2009-11-09 08:06:47 UTC
Any status update?
Comment 10 daniel.rentz 2009-11-09 08:58:22 UTC
in progress...
Comment 11 daniel.rentz 2009-11-11 16:34:52 UTC
fixed in OOO320/calc32stopper5
Comment 12 daniel.rentz 2009-11-13 09:36:51 UTC
back to QA
Comment 13 daniel.rentz 2009-11-13 09:38:09 UTC
Note: reproducible on Snow Leopard only.
Comment 14 oc 2009-11-20 11:19:15 UTC
verified in internal build cws_calc32stopper5
Comment 15 malte_timmermann 2010-01-08 09:14:14 UTC
Fixed and integrated => closing now..