Issue 10538 - Cut-&-Paste Characters from OO to WordPad incorrectly carry the font names and/or style names
Summary: Cut-&-Paste Characters from OO to WordPad incorrectly carry the font names an...
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: 643C
Hardware: PC Windows 2000
: P3 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords: ms_interoperability, oooqa
Depends on:
Blocks: 19112 20264
  Show dependency tree
 
Reported: 2003-01-09 02:28 UTC by Unknown
Modified: 2013-08-07 14:41 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Screen dump showing the problem (36.97 KB, application/octet-stream)
2003-01-09 02:29 UTC, Unknown
no flags Details
test document setting typeface to Kai (5.07 KB, application/octet-stream)
2003-06-20 15:32 UTC, Unknown
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Unknown 2003-01-09 02:28:20 UTC
This is based on my compile version with language setting Chinese Traditional. 

To simulate:

1. In WIN2k platform with Chinese Traditional language option installed.
2. New a Writer document.
3. Type in "This is a testing"
4. Cut-&-Paste the sentence from OO to WordPad

The Chinese version of style name "Standard" appears in front of "This is a 
testing".

This problem does not happens if the installed OO version is English.
Comment 1 Unknown 2003-01-09 02:29:12 UTC
Created attachment 4247 [details]
Screen dump showing the problem
Comment 2 h.ilter 2003-01-15 14:47:37 UTC
Seems to be a font stuff
Comment 3 Unknown 2003-01-16 01:57:34 UTC
It seems WordPad is selecting the RTF format data in clipboard. 
The stuff is font name in Chinese. Sometimes the style name such 
as "standard" in Chinese are shown.
Comment 4 prgmgr 2003-06-14 16:09:54 UTC
Thank you for using and supporting OOo.

Does this problem still exist in 1.0.3.1 or 1.1 Beta 2?
Comment 5 waiterevo 2003-06-14 18:30:15 UTC
The problem is still there. 

If I choose "Paste special" under WordPad, I can see two 
options: "Paste RTF text" and "Paste Unformmatted" text. 
Selecting "RTF" will cause the problem.
Comment 6 ulf.stroehler 2003-06-19 13:34:59 UTC
WaiTing Li,

could you pls. attach a sample document (OOo Writer *.sxw format)
containing a chines string that shows the error upon pasting into
Wordpad. Thanks.

us->es: could you pls. take over. Looks like a Clipboard bug.
Comment 7 eric.savary 2003-06-20 14:54:54 UTC
Maybe duplicate of issue 12713.
Waiting for inetegration of cws sw017 to the master.
Comment 8 Unknown 2003-06-20 15:32:11 UTC
Created attachment 7016 [details]
test document setting typeface to Kai
Comment 9 eric.savary 2003-07-03 19:06:53 UTC
ES->DVO: No it was not a duplicate :(
Still reproducible in a 645m9s3-3_86
Comment 10 prgmgr 2003-07-22 20:10:57 UTC
Added MS keyword
Comment 11 openoffice 2003-09-18 16:53:36 UTC
dvo->cmc: I suspect it's an RTF problem. Could you have a look at it?
Comment 12 caolanm 2003-09-19 12:30:08 UTC
To be fair the rtf generated by OOo is good, its just that
wordpad can't handle unicode only characters for fontnames which is
why the name appears when cut and pasted, word can.

It may be possible to improve this to use the mechanism that word uses
to hack around this sort of issue.
Comment 13 caolanm 2003-09-19 16:32:32 UTC
Ok, fixable (though a lot more work than I thought) for 2.0. Quite a
few changes needed to keep both wordpad and word happy at the same
time. Fixed in kilkennyfilterteam14 for 2.0
Comment 14 caolanm 2003-10-17 16:14:19 UTC
Reopen to reassign
Comment 15 caolanm 2003-10-17 16:14:50 UTC
cmc->mru: Fixed in kilkennyfilterteam14
Comment 16 michael.ruess 2003-11-04 14:32:47 UTC
Fixed in CWS kilkennyfilterteam14.
Comment 17 michael.ruess 2003-11-04 14:33:17 UTC
Verified. Fix will be included in OO 2.0.
Comment 18 michael.ruess 2003-11-27 10:17:02 UTC
Fix good in Oo 2.0 snapshot src680m13.