Issue 105476 - Crash in help browser displaying help for "data" (Writer)
Summary: Crash in help browser displaying help for "data" (Writer)
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: DEV300m60
Hardware: PC Solaris
: P2 Trivial (vote)
Target Milestone: OOo 3.2
Assignee: joerg.skottke
QA Contact: issues@framework
URL:
Keywords: regression
Depends on:
Blocks: 99999
  Show dependency tree
 
Reported: 2009-09-30 11:52 UTC by joerg.skottke
Modified: 2009-11-16 11:47 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description joerg.skottke 2009-09-30 11:52:09 UTC
Autotest: framework/optional/f_help_topics.bas

Reproduction
- Open help
- Select Index tab
- Select Writer application
- Search for "data"
- display topic
- move down one topic (cursor)
- display topic
Repeat last two steps until application crashes.
Comment 1 joerg.skottke 2009-09-30 12:05:02 UTC
Please use Solaris x86 to reproduce, it appears that just displaying enough topics causes the help 
viewer to crash at some point. Stacks have been submitted but are not yet available
Comment 2 joerg.skottke 2009-09-30 12:46:54 UTC
Stack-ID is: r4hrrdc
Comment 3 joerg.skottke 2009-09-30 12:50:01 UTC
Crash -> P2
Comment 4 joerg.skottke 2009-09-30 12:53:57 UTC
Last 100% good build was m48, following builds had warnings (up to m57 which 
was the last time cat3 tests where executed).
Comment 5 ab 2009-09-30 13:24:22 UTC
ab->mav: Stack shows no xmlhelp related entries.
Please have a look if help viewer code is involved.
Comment 6 mikhail.voytenko 2009-10-14 07:29:46 UTC
The main reason for the crash was memory corruption. There were three problems
that have affected the scenario and could cause the memory corruption:
- sal IO implementation had no mutex, it was not necessary before, but buffered
IO needs mutex to be thread safe
- xmlhelp implementation has used pointer to array that has been deleted already
- package implementation had no mutex on stream creation

The first and the third problems are related to multithreading, since the images
are loaded in different thread for html pages ( help uses html filter ). The
fixes are ready, I will look for cws.
Comment 7 mikhail.voytenko 2009-10-14 08:20:29 UTC
The fix is commited in fwk123.
Comment 8 mikhail.voytenko 2009-10-14 11:44:41 UTC
mav->jsk: Please verify the issue.
Comment 9 joerg.skottke 2009-10-15 12:27:04 UTC
Started QA on this issue.
Comment 10 joerg.skottke 2009-10-16 08:46:34 UTC
Looks good on Solaris x86, setting verified.
Comment 11 joerg.skottke 2009-11-16 11:47:44 UTC
Good in m3, closing