Issue 105522 - resizing and copying doesn't work in readonly spreadsheets
Summary: resizing and copying doesn't work in readonly spreadsheets
Status: CLOSED DUPLICATE of issue 22975
Alias: None
Product: Calc
Classification: Application
Component: editing (show other issues)
Version: OOO310m9
Hardware: Unknown All
: P2 Trivial with 3 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-01 17:12 UTC by erh
Modified: 2017-05-20 09:53 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: 4.1.0
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description erh 2009-10-01 17:12:54 UTC
This problem actually exists in OOO310m19 (which isn't in the list of versions)

When a document is readonly, it is impossible to resize columns.  This makes it
very hard to see what is in the spreadsheet if the columns aren't already sized
appropriately.  It is also impossible to highlight any portion of a cell, so
it's impossible to copy the text.  When I try, it pops up a rather unhelpful
message that says: "Document opened in read-only mode".

Even though I can't save back to the original file it should be possible for me
to modify what I see on my screen.  At most, the message about the document
being read-only should be a warning that still allows me to work with the
spreadsheet.  They way it works now, I'm basically *required* to make an extra
copy of any spreadsheet file, even if I just want to look at it.
Comment 1 lideln 2012-08-06 13:05:46 UTC
I agree, this is extremely not user-friendly to be unable to change layout or copy data or even modify data (without being able to overwrite a read-only file, of course).

It should really be changed.

Thanks in advance,
Comment 2 Terry 2012-08-06 23:36:55 UTC
There seems to be no reason to prevent changes as long as the edited document cannot be saved so as to overwrite the original.
Comment 3 Terry 2012-08-06 23:37:55 UTC
*** This issue has been confirmed by popular vote. ***
Comment 4 mroe 2014-05-07 08:52:27 UTC
Same as issue 22975.

*** This issue has been marked as a duplicate of issue 22975 ***