Issue 105568 - Split Cell Values accept negative number and special character.
Summary: Split Cell Values accept negative number and special character.
Status: CONFIRMED
Alias: None
Product: Impress
Classification: Application
Component: formatting (show other issues)
Version: OOo 3.1.1
Hardware: All All
: P4 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-03 09:10 UTC by omkarad
Modified: 2017-05-20 11:08 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Attached shows what various invalid inputs are changed to in Writer, Impress and Draw (11.89 KB, application/vnd.oasis.opendocument.spreadsheet)
2010-01-27 16:59 UTC, pacter
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description omkarad 2009-10-03 09:10:54 UTC
Steps to replicate bug.

1) Open a new presentation.
2) Insert a table into presentation.
3) Go to table option and select split cell option.
4) Select split cell horizontally option and insert any special character or 
negative number in "Split Cell into".
5) Instead of showing a error message it by defaults splits into 2 parts.
 
I tried to replicate this in Microsoft Presentation it clearly show error either 
"enter a valid number" or "Enter number between 2 to 63".

I tried this on System Configuration

Intel Pentium Dual CPU T3200
3 GB RAM
Windows Vista 32 bit system.

Open Office Version OOO310m19(Build:9420).
Comment 1 jbf.faure 2009-10-04 09:29:40 UTC
I can reproduce the problem with OOo 3.1.1 FR and OOODEV_m60. From my point of
view it is not a serious defect but Impress should show an error message because
the user maybe disturbed if he presses, for example, the " button instead of
shift+" to obtain 3 (example for FR keyboard).

Regards
JBF
Comment 2 wolframgarten 2009-10-07 13:58:28 UTC
Reproducible. Reassigned.
Comment 3 jungblutmarina 2010-01-25 01:11:30 UTC
OS: Windows Vista SP2 32-bit
OpenOffice: 3.1.1

I managed to reproduce the same failure on OO Writer. Following the same steps,
I get no warnings when trying to insert negative or non-numeric values.

Follow-up tests revealed that the problem also happens for values above the
default upper bound (which appears to be 20). If you try to split a single cell
into a value more than 20, the value is set back to 20. These similar steps will
reveal the unexpected behavior:

1) Create an empty file
2) Insert a table of any size
3) Put the cursor inside one of the cells
4) Go to Table->Split Cell
5) Insert any value greater than 20

The cell will be split into 20 cells.

I don't believe this is a serious issue. But it would be appropriate for the
program to show an error/warning message to the user.
Comment 4 pacter 2010-01-27 16:57:26 UTC
I do not believe this to be a bug, but actually a method of error handling that
is different than Microsoft Office applications, so it can easily seem like a
bug.  Instead of outputting an error message, OpenOffice automatically corrects
the error.  If an invalid integer is entered, OpenOffice rounds the value to the
closest valid value.  If a floating point number (a number with a decimal point)
is entered, OpenOffice rounds that number to the closest valid integer.  For any
other invalid value, OpenOffice changes the value to the last valid value that
was entered.  When the split cell window is initially opened, by default the
value 2 is entered as the split cell into value.  2 is the smallest number of
ways a cell can be split into, so entered an invalid negative number would
result that value being replaced by 2.  Also, entering a special character would
result in that value being changed to 2.  That is why when a negative number or
a special character is entered, it splits the cell into 2.  This type of error
checking occurs all over OpenOffice.  If you try to enter an invalid value for
font size, this also occurs.

Attached shows what various invalid inputs are changed to in Writer, Impress and
Draw.

I have tried successfully to reproduce this in Writer, Impress and Draw.
This also occurs if you select split cell vertically in Writer, Impress and Draw.  

It does not seem to matter if it is a new or existing document, the result has
been the same every time.
Comment 5 pacter 2010-01-27 16:59:41 UTC
Created attachment 67440 [details]
Attached shows what various invalid inputs are changed to in Writer, Impress and Draw
Comment 6 pacter 2010-01-27 17:03:03 UTC
The system I used to test with:

OS: KDE 3.2.1
OpenOffice 3.1.1
Version: OOO310m19 (Build:9420)
Comment 7 Marcus 2017-05-20 11:08:21 UTC
Reset assigne to the default "issues@openoffice.apache.org".