Issue 105764 - Job control is disabled
Summary: Job control is disabled
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: DEV300m59
Hardware: All All
: P2 Trivial (vote)
Target Milestone: OOo 3.2
Assignee: wolframgarten
QA Contact: issues@framework
URL:
Keywords:
: 105829 106273 (view as issue list)
Depends on:
Blocks: 104695 105185
  Show dependency tree
 
Reported: 2009-10-09 15:16 UTC by groucho266
Modified: 2017-05-20 10:29 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description groucho266 2009-10-09 15:16:52 UTC
Due to a change in recently integrated oj18 the framework Job control has been
disabled.

In framework/source/jobs/job.cxx in the Job::execute() method the line
    if ( ::comphelper::UiEventsLogger::isEnabled() )
essentially disables the execution of jobs in the directly following try/catch
block.
Comment 1 carsten.driesner 2009-10-09 15:29:30 UTC
cd: Thanks for the issue. This is a very severe issue as all jobs are disabled
when the uieventlogger itself is disabled. This is definitely wrong

cd: From my point of view this is a OOo 3.2 beta show stopper.

cd->oj: Could you please tell the purpose of this change. According to svn you
introduced this if-clause with oj18.
Comment 2 carsten.driesner 2009-10-09 15:30:07 UTC
cd: Set some people on CC.
Comment 3 Oliver Brinzing 2009-10-09 17:23:14 UTC
please have a look here:

OODEV32m58: com.sun.star.task.XJob - broken "OnStartApp" event ?
http://www.openoffice.org/issues/show_bug.cgi?id=105100
Comment 4 mdxonefour 2009-10-10 06:45:02 UTC
CCed: md
Comment 5 ocke.janssen 2009-10-12 07:18:15 UTC
@cd: I can't explain it. Seems to be a copy&paste error. When searching for
::comphelper::UiEventsLogger::isEnabled() you always see the comment for issue
88653 which is missing here. None the less the braces are missing below the if
statement. I would never write such a if without braces. So to me it looks like
a paste bug.
Comment 6 carsten.driesner 2009-10-12 09:57:54 UTC
cd: Fixed. I removed the wrong if-clause which disables the main function of the
job service implementation.
Comment 7 carsten.driesner 2009-10-12 10:35:59 UTC
cd->wg: Please verify the fix.
Comment 8 wolframgarten 2009-10-12 12:55:30 UTC
Verified in CWS. Presenter console comes up again.
Comment 9 Olaf Felka 2009-10-12 17:21:40 UTC
*** Issue 105829 has been marked as a duplicate of this issue. ***
Comment 10 thomas.lange 2009-10-26 10:16:29 UTC
*** Issue 106273 has been marked as a duplicate of this issue. ***