Issue 105824 - brackets in formulas not displayed
Summary: brackets in formulas not displayed
Status: CONFIRMED
Alias: None
Product: Impress
Classification: Application
Component: viewing (show other issues)
Version: OOO310m19
Hardware: PC Linux, all
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-12 13:22 UTC by rggjan
Modified: 2017-05-20 10:44 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: 4.1.0-dev
Developer Difficulty: ---


Attachments
Faulty document, see page 9 (3.32 MB, application/vnd.ms-office)
2009-10-12 13:25 UTC, rggjan
no flags Details
PDF of the same document, to compare. (4.00 MB, application/pdf)
2009-10-12 13:27 UTC, rggjan
no flags Details
Screenshot 1 (58.70 KB, image/png)
2009-10-12 15:25 UTC, rggjan
no flags Details
Screenshot 2 (53.94 KB, text/plain)
2009-10-12 15:26 UTC, rggjan
no flags Details
working example (14.85 KB, application/vnd.oasis.opendocument.presentation)
2009-10-15 08:58 UTC, rggjan
no flags Details
working example, as I see it... (13.52 KB, application/pdf)
2009-10-15 08:59 UTC, rggjan
no flags Details
screenshot of the problem as seen in the PDF (2.22 KB, image/png)
2010-06-23 10:36 UTC, hdu@apache.org
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description rggjan 2009-10-12 13:22:40 UTC
OpenOffice doesn't display the brackets (and other things) correctly in the
attached document. See page 9 for example. Compare to the pdf document, that I
also uploaded.

Only little squares are displayed...

Interestingly, double-clicking on one of the formulas in Impress opens the
OpenOffice Math module, where everything is displayed correctly.
Comment 1 rggjan 2009-10-12 13:25:58 UTC
Created attachment 65312 [details]
Faulty document, see page 9
Comment 2 rggjan 2009-10-12 13:27:28 UTC
Created attachment 65313 [details]
PDF of the same document, to compare.
Comment 3 wolframgarten 2009-10-12 13:39:50 UTC
Sorry, seems ok for me. Could you attach a screenshot, please?
Comment 4 rggjan 2009-10-12 15:24:38 UTC
Yes, of course... could it be some fonts issue or something?

I'm using archlinux, openoffice-base 3.1.1-2, and ttf-dejavu 2.30-1 is installed.
Comment 5 rggjan 2009-10-12 15:25:41 UTC
Created attachment 65317 [details]
Screenshot 1
Comment 6 rggjan 2009-10-12 15:26:21 UTC
Created attachment 65318 [details]
Screenshot 2
Comment 7 Regina Henschel 2009-10-12 15:43:29 UTC
That looks like a font problem. Can you write such a formula with the OOo
formula editor in a new OOo-Document? If not, then the font "OpenSymbol" might
be not correctly installed.
Comment 8 rggjan 2009-10-15 08:58:02 UTC
Yes, it seems like I can create such formulas. See the attached odp and the pdf
I generated...
Comment 9 rggjan 2009-10-15 08:58:58 UTC
Created attachment 65379 [details]
working example
Comment 10 rggjan 2009-10-15 08:59:54 UTC
Created attachment 65380 [details]
working example, as I see it...
Comment 11 Regina Henschel 2009-10-15 11:21:46 UTC
If you do not need to edit the formulas, you can try to open the document
without converting the math formulas. That is in Tools > Options > Load/Save.
Then the embedded preview pictures are shown.

Do you have set any font replacement?

I cannot reproduce your problem. But I have got WinXP and not Linux. Perhaps you
go to a Linux forum and discuss there, whether your system has configured fonts
correctly? 
Comment 12 rggjan 2009-10-17 15:47:07 UTC
No, this happens with deleted (=> standard) OpenOffice.org settings.

Also, changing something in "Tools > Options > Load/Save" does not help.
Comment 13 wolframgarten 2010-04-08 12:29:18 UTC
@hdu: could this be a fontproblem?
Comment 14 wolframgarten 2010-06-23 09:30:56 UTC
Reassigned. Could you please add a comment, hdu? Thanks.
Comment 15 hdu@apache.org 2010-06-23 10:36:12 UTC
Created attachment 70167 [details]
screenshot of the problem as seen in the PDF
Comment 16 hdu@apache.org 2010-06-23 10:39:17 UTC
@rggjan: please try a newer version of OOo (the latest is OOo321)

@tl: if it can be reproduced with a newer version then it is most likely a Math problem. Please see my 
screenshot above. How are adaptive brackets implemented?
Comment 17 thomas.lange 2010-06-23 10:57:59 UTC
Two problems with this issue:
a) I can't open the ppt file at all with DEV300_m83 (-> general IO error)
b) from the screen shot attached by HDU it is clearly visible that it is not
starmath what is used for displaying the formula!

tl->wg: setting you as owner for the time being as discussed with hdu.
Comment 18 thomas.lange 2010-06-23 11:19:15 UTC
More Info:

a) The problem with not being able to load happened only in a specific CWS of
mine. :-(

b) The ppt file contains MS MathType Equations (v 3.1, standard Word version).
And usually you need a MathType OLE server to display those. However MathType is
only available for Windows and Mac. Thus either the user (who report this one
for Linux) has some other type of OLE server that handles MathType (in that case
it is not our problem at all), or

c) the user is required to set the 'MathType to OOO Math' conversion option in
the Load/Save options of OOO. In this case however it works just fine for me,
and as said above the image attached from HDU can not have been rendered by
starmath.

d) another thing worthwhile to check is if only the replacement image is broken.
In that case the application that rendered it (Powerpoint?) is at fault.
(Looking at the first two screen shots this seems to be the case. That is if the
formulas got not opened/modified between creation of the doc and taking the
screen shots.)

tl->rggjan: do you knwo with what application the ppt document was created?
Comment 19 rggjan 2010-07-29 13:04:14 UTC
I don't know with what it was created.

I just tried it with OOO320m19 (Build: 9505), but have still the same problem:

-> Squares in openoffile
-> After a double click: Nice brackets in OOo Math

This happens, when I enable the "the 'MathType to OOO Math' conversion option in
the Load/Save options of OOO":

-> When I open the document, it looks the same, just squares instead of brackets
-> Double clicking on one formula shows again nice brackets, but this time
*within impress and still showing the whole slide*, when before, it showed the
formula *in an extra ooo math window, without the slide*
-> Going out of the formula editor, the brackets I double clicked on remain,
while others are still showed as squares
-> Closing Impress asks me if I want to save modifications
Comment 20 Rob Weir 2013-02-02 02:59:08 UTC
This Issue requires more information ('needmoreinfo'), but has not been updated
within the last year. Please provide feedback as requested and re-test with the the latest version of OpenOffice - the problem(s) may already be addressed. 

You can download Apache OpenOffice 3.4.1 from http://www.openoffice.org/download

Please report back the outcome of your testing, so this Issue may be closed or
progressed as necessary - otherwise the issue may be Resolved as Invalid in the
future.
Comment 21 Edwin Sharp 2014-04-16 17:34:56 UTC
Confirmed with
AOO410m17(Build:9763)  -  Rev. 1586584
2014-04-11 09:13 - Linux x86_64
Debian
Comment 22 Marcus 2017-05-20 10:44:40 UTC
Reset the assignee to the default "issues@openoffice.apache.org".