Issue 105945 - text search finds a lot of wrong texts
Summary: text search finds a lot of wrong texts
Status: CLOSED FIXED
Alias: None
Product: Internationalization
Classification: Code
Component: ui (show other issues)
Version: OOO320m2
Hardware: Sun Solaris
: P3 Trivial (vote)
Target Milestone: ---
Assignee: kla
QA Contact: issues@l10n
URL:
Keywords:
Depends on:
Blocks: 99999 119332
  Show dependency tree
 
Reported: 2009-10-16 09:02 UTC by Frank Schönheit
Modified: 2013-08-07 15:02 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
document to reproduce the bug case (9.07 KB, application/vnd.oasis.opendocument.text)
2009-10-16 09:03 UTC, Frank Schönheit
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Frank Schönheit 2009-10-16 09:02:22 UTC
(not sure this is the right component ...)
- open the attached text document
- Edit/Find and Replace
- enter "record pointer" as search expression
- press the "Find" button repeatedly
=> 3 occurrences are found, but every time, the found text is not "record
   pointer", but something else. The only commonality seems to be that the
   found texts also have 14 characters, and start and end with "r".

Notes:
- I encountered this bug in the Solaris-x86-build, but could *not* reproduce
  it in the Windows and Linux (32bit) builds
- Pasting the text to a spreadsheet and searching the same term there gives
  the same (wrong) result, which makes me think that this is not a Writer
  problem, but a problem of some underlying core component.
Comment 1 Frank Schönheit 2009-10-16 09:03:13 UTC
Created attachment 65397 [details]
document to reproduce the bug case
Comment 2 Frank Schönheit 2009-10-16 09:05:20 UTC
nominating as 3.2 blocker
Comment 3 niklas.nebel 2009-10-16 09:40:20 UTC
Looks like a problem with optimization in textsearch.cxx.
Comment 4 niklas.nebel 2009-10-16 13:34:53 UTC
taking the issue
Comment 5 niklas.nebel 2009-10-16 16:29:55 UTC
Fixed in CWS "calc32stopper4".

TextSearch::NSrchFrwrd is wrong with optimization. We should look at the issue
again if we upgrade the compiler for Solaris-x86.
Comment 6 niklas.nebel 2009-10-22 17:25:59 UTC
reassigning to QA for verification
Comment 7 kla 2009-10-28 10:05:27 UTC
In case of heavy workload, it take it.
Comment 8 kla 2009-10-29 13:13:38 UTC
Seen ok in cws calc32stopper4 (sol-intel only) -> verified
Comment 9 kla 2009-11-09 13:45:48 UTC
seen ok, closed