Issue 106033 - Hyperlinks broken in ODF conform TOCs
Summary: Hyperlinks broken in ODF conform TOCs
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOO320m2
Hardware: Unknown All
: P2 Trivial (vote)
Target Milestone: ---
Assignee: eric.savary
QA Contact: issues@sw
URL:
Keywords: regression
Depends on:
Blocks: 99999
  Show dependency tree
 
Reported: 2009-10-19 13:27 UTC by lendo
Modified: 2017-05-20 11:42 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Test document with broken TOCs; if you copy the whole content into a OOo 3.1 file and if you renew the TOC it will work as it should (11.30 KB, application/vnd.oasis.opendocument.text)
2009-10-19 13:29 UTC, lendo
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description lendo 2009-10-19 13:27:04 UTC
Hyperlinks are broken in TOCs (since Issue 103265 is fixed?). See the attached
Writer document.

Create a new text document in OOo320m2 (Build:9432; en-US, Windows XP), insert
some headings and make a table of content with hyperlinks for the whole TOC lines.

You will see that the page number at the right end is not underlined an can't be
clicked with ctrl + mouse click. Also the right half of the whole line is not
clickable although it is underlined like a real hyperlink.

With this defect TOCs with hyperlinks are only "half useful" in OOo 3.2 if it
will not be repaired before the official release.
Comment 1 lendo 2009-10-19 13:29:59 UTC
Created attachment 65441 [details]
Test document with broken TOCs; if you copy the whole content into a OOo 3.1 file and if you renew the TOC it will work as it should
Comment 2 Oliver-Rainer Wittmann 2009-10-20 08:37:03 UTC
I have reproduced the defect.

Investigation reveals that the following:
- defect occurs since DEV300m59 - earlier versions are ok.
- changes of issue 103265 are integrated into DEV300m57. Thus, these changes
does not cause the defect.

I vote for a nomination of this issue as a show stopper for OOo 3.2
Comment 3 Oliver-Rainer Wittmann 2009-10-20 08:37:58 UTC
forgot to set keyword "regression"
Comment 4 Oliver-Rainer Wittmann 2009-10-20 14:24:03 UTC
As this issue has been added to issue 99999 the target needs also to be adjusted.
Comment 5 mst.ooo 2009-10-20 15:20:50 UTC
fixed in CWS sw32bf06 (revision 277059)
Comment 6 Oliver-Rainer Wittmann 2009-10-23 12:04:01 UTC
OD->ES: Checked in internal installation set of cws sw32bf06 - please verify.
Comment 7 eric.savary 2009-10-29 16:35:05 UTC
Verified in CWS sw32bf06