Issue 106041 - Writer: Tools/Language menu broken
Summary: Writer: Tools/Language menu broken
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: OOO320m2
Hardware: All All
: P3 Trivial (vote)
Target Milestone: OOo 3.2
Assignee: stefan.baltzer
QA Contact: issues@framework
URL:
Keywords: regression
Depends on:
Blocks: 99999
  Show dependency tree
 
Reported: 2009-10-19 15:32 UTC by thomas.lange
Modified: 2009-12-01 09:45 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description thomas.lange 2009-10-19 15:32:29 UTC
The Tools/Language is broken. Reason is that in
framework/source/uielement/langselectionmenucontroller.cxx the function
impl_select is not called anymore.
Comment 1 thomas.lange 2009-10-19 15:33:53 UTC
.
Comment 2 thomas.lange 2009-10-19 15:42:34 UTC
To be more precisely 
- Tools/Language/For Selection
- Tools/Language/For Paragraph
- Tools/Language/For all text
do not work anymore.

Broken in DEV300_m58, still working in DEV300_m57.

TL->OJ: As discussed with CD, please take over.

Comment 3 carsten.driesner 2009-10-19 15:48:09 UTC
cd: Add to the show stopper list. Regression introduced by CWS oj18.

cd->oj: This is the 5th show stopper introduced by CWS oj18. I have no faith
that this is the last show stopper. I demand to revert all changes made by CWS
oj18 in the framework project and got approval by MD.
Comment 4 merschmann 2009-10-19 20:03:13 UTC
CCing myself
Comment 5 ocke.janssen 2009-10-20 06:43:47 UTC
Fixed in cws dba32i.

@cd: 5 issues in a 1mb patch file isn't that huge but that is my personal
opinion. ;-)

The fault was that xDispatch was checked too early. Some classes uses their own
hold dispatch and uses that one.
Comment 6 thomas.lange 2009-10-20 07:37:47 UTC
tl: please drop me a note once a CWS with this fix got integrated since I
already have a new OOo 3.3 CWS that changes code in that part and thus would
need to be resynced once the fix got integrated. Thanks!
Comment 7 ocke.janssen 2009-10-28 08:00:28 UTC
Please verify. Thanks.
Comment 8 stefan.baltzer 2009-10-30 12:34:53 UTC
Verified in CWS dba32i.
Comment 9 stefan.baltzer 2009-12-01 09:45:55 UTC
OK in OOO320_m6. Closed.