Issue 106307 - Writer hangs on bad RTF import
Summary: Writer hangs on bad RTF import
Status: CLOSED DUPLICATE of issue 32227
Alias: None
Product: Writer
Classification: Application
Component: open-import (show other issues)
Version: OOo 3.1
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: writerneedsconfirm
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-26 22:10 UTC by jpvossen
Modified: 2009-10-27 13:06 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Bad RTF file mis-named as .doc (52.72 KB, text/rtf)
2009-10-26 22:20 UTC, jpvossen
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description jpvossen 2009-10-26 22:10:59 UTC
Ubuntu Hardy using http://ppa.launchpad.net/openoffice-pkgs/ubuntu hardy main,
so: openoffice.org  3.1.0-5ubuntu1~hardy1

On opening an emailed attachment incorrectly named .doc when it is in fact (bad)
RTF, Writer hangs to the point that it won't even fully paint the screen
decorations.  The same thing happens when the file is downloaded and correctly
renamed RTF.

The file will open but not print (just get a blank page) in WordPad under wine,
on the same machine, but it does not render correctly (header at bottom instead
of top).

The file opens on MS Word 2003 on XP as expected.  Writer 3.1.0 on XP also hangs
at "importing document" with only 1 status block to go, though it did offer to
recover the file on restart, which did not happen on Ubuntu.  Recovery was
claimed successful but was not; the document was empty.

It appears that the file was created using calendarlabs.com, who should probably
be shot for called RTF ".doc".  Later, updated versions of the same file worked
fine, so this one just has bad RTF, which is why I'm reporting it, since OO.o
should at least bail gracefully, though ideally it should Just Work.  (MS craft
Just Works in this case, which is terribly sloppy any way you look at it, but...
 That's life in the real world.)-:
Comment 1 jpvossen 2009-10-26 22:20:58 UTC
Created attachment 65640 [details]
Bad RTF file mis-named as .doc
Comment 2 eric.savary 2009-10-26 23:55:43 UTC
Reproduced in OOO320m2 on Vista.

@MRU: please have a look.
Comment 3 michael.ruess 2009-10-27 13:06:40 UTC
Already tracked as issue 32227.

*** This issue has been marked as a duplicate of 32227 ***
Comment 4 michael.ruess 2009-10-27 13:06:58 UTC
Closing duplicate.