Issue 106522 - selecting some cells (vertically) and pasting them onto a row hangs the application
Summary: selecting some cells (vertically) and pasting them onto a row hangs the appli...
Alias: None
Product: Calc
Classification: Application
Component: editing (show other issues)
Version: OOO310m19
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: needhelp
Depends on:
Blocks: 30215
  Show dependency tree
Reported: 2009-11-01 11:19 UTC by nadavkav
Modified: 2014-03-24 10:27 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description nadavkav 2009-11-01 11:19:45 UTC
i selected some cells (D2:D320) and right clicked the row F and pasted them...
the Calc application hangs and hug the cpu
after several minutes... i killed the process.

the cells had text data (no calculations). both source and destination

if i run the same operation on a small amount of cells it works fine.
(lets say... 40-80 cells more or less)

it happened 3 times on different occasions (different sheets, of course)
i can reproduce it. any time.
Comment 1 jbf.faure 2009-11-01 21:59:22 UTC
Please attach a document showing the problem.
Which OOo version are you using ? It is the derived version provided by your
distribution or the official version from website ? If it is
distro version, please try with the official version.
Comment 2 nadavkav 2009-11-02 05:35:54 UTC
i am using Debian OOo 3.1.1-5 (3.1.1 - OOo 310m9 build 9420)

no need to attach a document.
1. fill cells A1:A300 with "sometext"
2. select cells A1:A300
3. right click header of row D & paste that selection.
4. application hangs.
Comment 3 raal 2009-11-16 21:19:46 UTC
I can reproduce with ubuntu 9.10, OOo 3.1.1 distro version,
but cannot reproduce with official version OOO320m4.
Comment 4 kyoshida 2009-11-16 21:59:57 UTC
Note that the distro version (aka go-oo) has the row limit extended to 1 million
rows, while the Sun version is still fixed at 64k.  That makes a huge difference
when pasting data to the entire column, since the destnation area is now 16
times as large.

On my machine the describe operation takes about 10 seconds, though my machine
is pretty fast development machine, so 10 seconds is considered a very long
time. ;-)

@nadavkav: can you at least verify that the paste operation eventually finishes?
 Depending on the speed of your machine it may take somewhere between 10 seconds
to a few minutes, but I need to know whether this is just a poor performance, or
a real hang.  Thanks.  --Kohei
Comment 5 raal 2009-11-17 07:21:24 UTC
@Kohei: On my machine it takes 10 min to finish paste operation. OOo doesn´t
crash. CPU T2500  @ 2.00GHz, 1GB RAM
Comment 6 kyoshida 2009-11-17 12:53:32 UTC
@raal: thanks for the confirmation.  This is then related to the row limit increase.
Comment 7 kyoshida 2009-11-17 12:53:58 UTC
Comment 8 kyoshida 2009-11-17 12:54:20 UTC
I'll look into this.
Comment 9 kami911 2009-11-20 07:54:36 UTC
I can confirm it on large selections with text (I tried with about 500 e-mail
addresses). I takes more then a minute. Inserting small - number only -
selections was fast on my laptop.

model name	: Intel(R) Core(TM)2 Duo CPU     T5750  @ 2.00GHz

I tested on Ubuntu 9.10/32 bit

With my build of go-oo version (oxygenoffice) 3.2 m5
Comment 10 thorsten.ziehm 2010-09-23 15:03:29 UTC
OOo 3.3 is in showstopper-mode. This issue is too old to be a stopper for the
current release. I change the target to OOo 3.x. Please change the target
accordingly when a fix is near to be integrated into a code line.
Comment 11 Rob Weir 2013-07-30 02:38:54 UTC
Reset assignee on issues not touched by assignee in more than 1000 days.
Comment 12 j.nitschke 2014-03-24 10:27:56 UTC
reset to confirmed (no assignee)

while reproducing the progress bar shows adjusting row heights and AOO is busy for a while

not sure if this is still a valid issue because progress is indicated