Issue 106526 - Query parameter must be entered twice in reports
Summary: Query parameter must be entered twice in reports
Status: CLOSED FIXED
Alias: None
Product: Base
Classification: Application
Component: ReportBuilder (show other issues)
Version: OOo 3.1.1
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: OOo 3.3
Assignee: marc.neumann
QA Contact: issues@dba
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-01 16:41 UTC by schaber
Modified: 2012-07-01 16:46 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Sample database and report (5.94 KB, text/plain)
2009-11-02 10:36 UTC, schaber
no flags Details
File to reproduce the bug (43.51 KB, application/vnd.oasis.opendocument.database)
2012-07-01 16:09 UTC, renatoyamane
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description schaber 2009-11-01 16:41:52 UTC
I have checked the forums about this problem, and it obviously happens to other
users as well, but I could not find any bug report that covers the problem.

I do not find any way to rework my query so that the report won't ask twice for
the parameter :FROM_DATE.

SELECT "ID", "ENTERDATE, "LEAVEDATE" FROM "MYTABLE" WHERE ( "LEAVEDATE" IS NULL
OR "LEAVEDATE" >= :FROM_DATE ) AND ( "ENTERDATE" IS NULL OR ( "ENTERDATE" >=
:FROM_DATE AND "ENTERDATE" <= :TO_DATE ) )

When executing the query it only asks once for :FROM_DATE, but when I use the
query in a report, it asks twice for it. This is annoying for users of the
report, besides it is error prone.
Comment 1 marc.neumann 2009-11-02 07:59:02 UTC
Hi,

can you attach a simple bug doc to reproduce this issue.

Thanks and bye Marc
Comment 2 schaber 2009-11-02 10:36:54 UTC
Created attachment 65847 [details]
Sample database and report
Comment 3 schaber 2009-11-02 10:39:00 UTC
A sample database and report is attached. Just open report R1 and enter 01.01.01
as FROMDATE and 31.01.01 as TODATE. The report asks twice for FROMDATE, but the
query Q1 asks only once.
Comment 4 Frank Schönheit 2009-11-06 17:49:54 UTC
confirming, assigning, targeting
Comment 5 ocke.janssen 2009-11-26 08:08:47 UTC
Fixed in cws dba33d.

For testing, the same happens when trying to D&D the query onto the table container.
Comment 6 ocke.janssen 2009-12-18 09:02:09 UTC
Please verify. Thanks.
Comment 7 schaber 2009-12-20 13:23:34 UTC
Any chance to get the fix with OO 3.2?
Comment 8 ocke.janssen 2009-12-21 06:31:04 UTC
I'm sorry but the 3.2 line is closed as far it isn't a show stopper issue like 
a crash could be.

Best regards,

Ocke
Comment 9 marc.neumann 2010-01-13 13:40:04 UTC
verified in CWS dba33d

find more information about this CWS, like when it is available in the master
builds, in EIS, the Environment Information System:
http://eis.services.openoffice.org/EIS2/cws.ShowCWS?Path=DEV300%2Fdba33d
Comment 10 renatoyamane 2012-07-01 16:09:35 UTC
Created attachment 78526 [details]
File to reproduce the bug

I believe that the problem is happening again on 3.5.5 (RC2) on Linux Kubuntu 12.04 (64 bits).

The query works fine, but when you try open the REPORT, it ask you twice and **CRASH**!

Try open the file attached. When the report ask you about a CITY name, type "New York".

Same problem on LibreOffice:
https://bugs.freedesktop.org/show_bug.cgi?id=51619
Comment 11 Ariel Constenla-Haile 2012-07-01 16:46:46 UTC
(In reply to comment #10)
> Created attachment 78526 [details]
> File to reproduce the bug
> 
> I believe that the problem is happening again on 3.5.5 (RC2) on Linux
> Kubuntu 12.04 (64 bits).

There is no OpenOffice 3.5.5 RC2

> The query works fine, but when you try open the REPORT, it ask you twice and
> **CRASH**!
> 
> Try open the file attached. When the report ask you about a CITY name, type
> "New York".
> 
> Same problem on LibreOffice:
> https://bugs.freedesktop.org/show_bug.cgi?id=51619

It works fine with OpenOffice 3.4.0 

Closing bug.