Issue 106542 - python: build python ssl extension
Summary: python: build python ssl extension
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: DEV300m63
Hardware: All All
: P3 Trivial (vote)
Target Milestone: OOo 3.3
Assignee: h.ilter
QA Contact: issues@framework
URL:
Keywords:
: 104964 116347 (view as issue list)
Depends on:
Blocks:
 
Reported: 2009-11-02 10:04 UTC by caolanm
Modified: 2017-05-20 10:30 UTC (History)
1 user (show)

See Also:
Issue Type: PATCH
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
how to build against our openssl under windows (8.56 KB, patch)
2009-11-02 10:05 UTC, caolanm
no flags Details | Diff
_ssl.pyd (22.50 KB, application/octet-stream)
2009-11-02 10:06 UTC, caolanm
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description caolanm 2009-11-02 10:04:56 UTC
openssl is in our build tree, if we build the python ssl module then we can
support tls authentication in the python emailmerge component
Comment 1 caolanm 2009-11-02 10:05:32 UTC
Created attachment 65845 [details]
how to build against our openssl under windows
Comment 2 caolanm 2009-11-02 10:06:15 UTC
Created attachment 65846 [details]
_ssl.pyd
Comment 3 caolanm 2009-11-02 10:07:21 UTC
Under windows for testing, if you download the above attachment and save it to
c:\Program Files\OpenOffice.org 3\Basis\Program\python-core-2.6.1\lib\ssl.pyd
your emailmerge might begin to work with ssl/tls authentication. (e.g. gmail
uses this)
Comment 4 caolanm 2009-11-02 10:56:52 UTC
done in pythonssl
Comment 5 caolanm 2009-11-02 10:58:26 UTC
*** Issue 104964 has been marked as a duplicate of this issue. ***
Comment 6 caolanm 2009-11-02 11:01:37 UTC
To test, use a gmail account and...
tools->options->openoffice.org writer->email settings
a) an smtp server of smtp.gmail.com at port 587
b) ssl checked
server authentication
c) The outgoing mail server requires authorization checked
d) The outgoing mail server requires separate authentication checked
   username@gmail.com
   password
Comment 7 caolanm 2009-12-01 10:41:46 UTC
To test, see above comment and use "test settings...", should be green for
establish network connection and find outgoing mail server. gmail is an example,
but any mail server that needs ssl will do
Comment 8 h.ilter 2009-12-14 14:54:24 UTC
Verified with cws pythonssldedux = ok
Comment 9 eric.savary 2011-01-07 11:20:11 UTC
*** Issue 116347 has been marked as a duplicate of this issue. ***