Issue 106568 - Find outgoing mail server fails
Summary: Find outgoing mail server fails
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: configuration (show other issues)
Version: OOO310m19
Hardware: Other Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: h.ilter
QA Contact: issues@sw
URL:
Keywords:
: 108023 110397 (view as issue list)
Depends on:
Blocks:
 
Reported: 2009-11-02 22:36 UTC by cckozie
Modified: 2017-05-20 11:41 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Screen shots and errors (120.33 KB, application/vnd.oasis.opendocument.text)
2009-11-02 22:39 UTC, cckozie
no flags Details
Screen shots of configuration test not working (159.99 KB, image/png)
2010-02-15 23:00 UTC, chriscant
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description cckozie 2009-11-02 22:36:55 UTC
When configuring the email server information for mailmerge and clicking the 
Test Setting button I get an error indicating that the "Find outgoing mail 
server" failed if configured to connect to a server that requires 
authentication. The test passes when not specifying to use authentication. I 
have attempted to use both the gmail and hotmail servers and get the same 
results in both cases (they both require authentication).

If I attempt to perform the email merge I get the following trace data:
<class 'socket.error'>: (10054, 'An existing connection was forcibly closed by 
the remote host'), traceback follows
  C:\Program Files\OpenOffice.org 3\Basis\program\python-core-2.6.1
\lib\socket.py:404 in function readline() [data = self._sock.recv
(self._rbufsize)]
  C:\Program Files\OpenOffice.org 3\Basis\program\python-core-2.6.1
\lib\smtplib.py:337 in function getreply() [line = self.file.readline()]
  C:\Program Files\OpenOffice.org 3\Basis\program\python-core-2.6.1
\lib\smtplib.py:450 in function mail() [return self.getreply()]
  C:\Program Files\OpenOffice.org 3\Basis\program\python-core-2.6.1
\lib\smtplib.py:695 in function sendmail() [(code,resp) = self.mail(from_addr, 
esmtp_opts)]
  C:\Program Files\OpenOffice.org 3
\share\uno_packages\cache\uno_packages\40.tmp_\mailmerge.py:193 in function 
sendMailMessage() [self.server.sendmail(sendermail, truerecipients, 
msg.as_string())]

I've tried the suggestions in issue 106542 to no avail. Also tried it using 
latest dev build with the same result.
Comment 1 cckozie 2009-11-02 22:39:38 UTC
Created attachment 65875 [details]
Screen shots and errors
Comment 2 caolanm 2009-11-03 15:21:38 UTC
I'll build some windows install sets with the proposed fixes I have for the
missing ssl support in windows python, which is possible also the reason for
this error.
Comment 3 caolanm 2009-11-10 10:50:55 UTC
If you're willing to try a test, I have a windows .zip of a development install
set at ftp://qa-upload.services.openoffice.org/pythonssldedux/windows/ which has
some changes in it that affect ssl authentication and cram-md5 authentication
and I'd be interested in knowing if it makes a difference to your reported issue
Comment 4 cckozie 2009-11-10 20:12:11 UTC
The problem is fixed in your development install. Everything works as expected.
Thanks for the quick resolution. Will this fix be in the anticipated December 
release?
Comment 5 caolanm 2009-11-11 08:53:22 UTC
Neat. Unfortunately this has missed the 3.2 deadline (I didn't have any windows
machines to debug this until recently), but it will be in 3.3
Comment 6 cckozie 2009-11-12 16:02:17 UTC
Is the fix something that is relatively small so it could be patched into 3.1 
or 3.2?
Comment 7 caolanm 2009-12-01 10:46:20 UTC
cmc->hi: See issue 106542 for a how-to on testing this one.

cmc->cckozie: Well if you copy the "emailmerge.py" and entire OpenOffice.org
3/Basis/program/python-core-2.6.1 dir from the above testing packages and
overwrite a normal one with those then that would probably work. Mileage may vary.
Comment 8 h.ilter 2009-12-14 15:16:18 UTC
Verified with cws pythonssldedux & gmail account = ok
Comment 9 chriscant 2010-02-15 22:58:07 UTC
I'm seeing a very similar problem: my mail server requires SMTP authentication 
but does not use SSL.  In Test Settings, Establish network connection fails.  
The email merge also fails because unauthenticated relay is not allowed.

I've tried the pythonssldedux/windows/ patch with no success.

I'm running Windows 7.  
Comment 10 chriscant 2010-02-15 23:00:40 UTC
Created attachment 67843 [details]
Screen shots of configuration test not working
Comment 11 h.ilter 2010-03-26 12:13:02 UTC
*** Issue 110397 has been marked as a duplicate of this issue. ***
Comment 12 h.ilter 2010-03-26 12:31:22 UTC
*** Issue 108023 has been marked as a duplicate of this issue. ***