Issue 106601 - templwin.cxx: template url should be configurable
Summary: templwin.cxx: template url should be configurable
Status: CONFIRMED
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: OOo 3.1.1
Hardware: Unknown All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks: StartCenter
  Show dependency tree
 
Reported: 2009-11-04 12:05 UTC by Oliver Brinzing
Modified: 2017-05-20 10:47 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Oliver Brinzing 2009-11-04 12:05:01 UTC
[...]
void SvtDocumentTemplateDialog::InitImpl( )
{
	pImpl = new SvtTmplDlg_Impl( this );
	pImpl->aTitle = GetText();

    aMoreTemplatesLink.SetURL( String(
        RTL_CONSTASCII_STRINGPARAM(
"http://templates.services.openoffice.org/?cid=923508" ) ) );
    aMoreTemplatesLink.SetClickHdl( LINK( this, SvtDocumentTemplateDialog,
OpenLinkHdl_Impl ) );
[...]

imho the template url should be also configurable in Common.xcu

 <node oor:name="Help">
  <node oor:name="StartCenter">
	<prop oor:name="TemplateRepositoryURL" oor:type="xs:string">
		<value></value>
	</prop>
	<prop oor:name="AddFeatureURL" oor:type="xs:string">
		<value></value>
	</prop>
	<prop oor:name="InfoURL" oor:type="xs:string">
		<value></value>
	</prop>
 </node>
</node>
Comment 1 Olaf Felka 2009-11-25 12:04:58 UTC
@ mav: Something for you?
Comment 2 mikhail.voytenko 2009-11-25 12:28:27 UTC
Sounds reasonable, but it is of course no defect.
Comment 3 Oliver Brinzing 2009-11-30 17:22:35 UTC
added to http://www.openoffice.org/issues/show_bug.cgi?id=107318
(Collecting StartCenter improvements)
Comment 4 Oliver Brinzing 2009-11-30 17:27:06 UTC
in addition: 
if an url is not set (e.g. <value/> is empty) the corresponding start center
symbol shoud be disabled or hidden.
Comment 5 Oliver Brinzing 2013-03-14 10:26:01 UTC
starting from oo321 it seems to be possible to remove symbols with 

<?xml version="1.0" encoding="UTF-8"?>
<oor:component-data xmlns:oor="http://openoffice.org/2001/registry" 
xmlns:xs="http://www.w3.org/2001/XMLSchema" oor:name="Common" 
oor:package="org.openoffice.Office">
   <node oor:name="Help">
       <node oor:name="StartCenter">
           <prop oor:name="StartCenterLayoutStyle" oor:type="xs:int">
               <value>2</value>
           </prop>
       </node>
   </node>
</oor:component-data>
Comment 6 Marcus 2017-05-20 10:47:57 UTC
Reset assigne to the default "issues@openoffice.apache.org".